Bug 590502 - [PATCH] yum-builddep does not work at all
Summary: [PATCH] yum-builddep does not work at all
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-utils   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: James Antill
QA Contact: Petr Sklenar
URL:
Whiteboard:
Keywords: EasyFix, Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-09 23:41 UTC by Lubomir Rintel
Modified: 2014-01-21 06:17 UTC (History)
2 users (show)

Fixed In Version: yum-utils-1.1.26-7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 22:01:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix (2.28 KB, text/plain)
2010-05-09 23:41 UTC, Lubomir Rintel
no flags Details

Description Lubomir Rintel 2010-05-09 23:41:47 UTC
Created attachment 412688 [details]
Proposed fix

Description of problem:

# yum-builddep xorg-x11-drv-nouveau-0.0.15-17.20091105gite1c2efd.el6.src.rpm
Loaded plugins: priorities, refresh-packagekit, rhnplugin
This system is not registered with RHN.
RHN support will be disabled.
6312 packages excluded due to repository priority protections
Traceback (most recent call last):
  File "/usr/bin/yum-builddep", line 196, in <module>
    util = YumBuildDep()
  File "/usr/bin/yum-builddep", line 64, in __init__
    self.main()
  File "/usr/bin/yum-builddep", line 93, in main
    self.get_build_deps()
  File "/usr/bin/yum-builddep", line 173, in get_build_deps
    for srpm in toActOn:
UnboundLocalError: local variable 'toActOn' referenced before assignment

Version-Release number of selected component (if applicable):

yum-utils-1.1.24-4.el6.noarch

Additional info:

Attaching a fix

Comment 2 RHEL Product and Program Management 2010-05-10 01:19:59 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 James Antill 2010-05-10 14:21:02 UTC
 Can you try with the post beta1 versions of:

yum-3.2.27-7.el6
yum-utils-1.1.26-7.el6

Comment 4 Lubomir Rintel 2010-05-13 07:59:28 UTC
James, I would love to, but I do not know where to download those packages.

Comment 5 James Antill 2010-05-20 19:19:55 UTC
Ok, pretty sure this is fixed in -7.

Comment 9 Petr Sklenar 2010-07-09 14:46:24 UTC
yum-builddep /mnt/redhat/brewroot/packages/zsh/4.3.10/4.1.el6/src/zsh-4.3.10-4.1.el6.src.rpm 
Loaded plugins: presto, refresh-packagekit, rhnplugin
Getting requirements for zsh-4.3.10-4.1.el6.src
 --> Already installed : coreutils-8.4-9.el6.x86_64
 --> Already installed : coreutils-8.4-9.el6.x86_64
 --> Already installed : sed-4.2.1-5.el6.x86_64
 --> ncurses-devel-5.7-3.20090208.el6.x86_64
 --> libcap-devel-2.16-5.2.el6.x86_64
...
# then 20 packages was installed successfully
...
Complete!
--
verified with yum-utils-1.1.26-10.el6.noarch
distro: RHEL6.0-20100706.n.0

Comment 10 releng-rhel@redhat.com 2010-11-10 22:01:21 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.