Bug 590505 - preupgrade should default to "Upgrade an Existing Installation"
preupgrade should default to "Upgrade an Existing Installation"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-09 20:23 EDT by Alex Lancaster
Modified: 2010-08-13 11:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-13 11:21:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log file (11.12 KB, text/plain)
2010-05-10 12:31 EDT, Alex Lancaster
no flags Details

  None (edit)
Description Alex Lancaster 2010-05-09 20:23:49 EDT
preupgrade defaults to highlighting "Fresh Installation" rather than "Upgrade an Existing Installation".  I would have thought it should default to highlighting the "Upgrade" option since that's the purpose of preupgrade, it might cause a user to inadvertantly override an existing system if they just accepted the defaults.
Comment 1 Chris Lumens 2010-05-10 10:34:16 EDT
Please attach /tmp/anaconda.log to this bug report.  If you're seeing that screen at all, it seems unlikely that your upgrade process is working as it should at all.
Comment 2 Alex Lancaster 2010-05-10 12:31:04 EDT
Created attachment 412898 [details]
anaconda.log file
Comment 3 Chris Lumens 2010-05-14 11:01:45 EDT
On the filter screen, did you select the drives in your system to be a part of the upgrade process?  Perhaps anaconda could not find your previous installation because it was not selected.
Comment 4 Alex Lancaster 2010-05-29 23:44:57 EDT
(In reply to comment #3)
> On the filter screen, did you select the drives in your system to be a part of
> the upgrade process?  Perhaps anaconda could not find your previous
> installation because it was not selected.    

You mean when running preupgrade before the download, or after the reboot inside anaconda?  I believe I did select a drive during the preupgrade, can't quite recall now.
Comment 5 Chris Lumens 2010-07-26 16:08:38 EDT
> You mean when running preupgrade before the download, or after the reboot
> inside anaconda?  I believe I did select a drive during the preupgrade, can't
> quite recall now.    

Inside anaconda.
Comment 6 Alex Lancaster 2010-07-26 23:58:21 EDT
(In reply to comment #5)
> > You mean when running preupgrade before the download, or after the reboot
> > inside anaconda?  I believe I did select a drive during the preupgrade, can't
> > quite recall now.    
> 
> Inside anaconda.    

It was a while back.  I think that was the first thing that preupgrade/anaconda presented after reboot.  The drive selection was during preupgrade before reboot IIRC.
Comment 7 Alex Lancaster 2010-07-31 17:22:16 EDT
I just did a fresh upgrade from another F-11 machine to F-13 and I first selected the drive in anaconda after reboot (not before rebooting as I erroneously said comment #6 above), then I was presented with the screen that had something like (this is from memory):

"Another installation has been detected, what would you like to do:

[x] Fresh installation

[ ] Upgrade existing

 <drop down box with F-11 installation in the list>"


If this has been done from preupgrade, this should default to the second choice, not the first.  Selecting the "upgrade existing" and then selecting the installation works, however I think the default selection of fresh installation is a bug.

Note You need to log in before you can comment on or make changes to this bug.