Bug 590518 - KeyError: <yuminstall.AnacondaYumRepo object at 0x7f459004d7d0>
Summary: KeyError: <yuminstall.AnacondaYumRepo object at 0x7f459004d7d0>
Status: CLOSED DUPLICATE of bug 505189
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:37fc4c8761a35d8ca...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-10 02:58 UTC by He Rui
Modified: 2010-05-10 08:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 08:54:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (261.14 KB, text/plain)
2010-05-10 02:59 UTC, He Rui
no flags Details

Description He Rui 2010-05-10 02:58:55 UTC
The following was filed automatically by anaconda:
anaconda 13.41 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 233, in _sql_MD
    cache = getattr(self.sack, MD + 'db')[self.repo]
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 46, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 381, in returnPrco
    cur = self._sql_MD('primary', sql, (self.pkgKey,))
  File "/usr/lib/python2.6/site-packages/yum/packages.py", line 488, in returnPrcoNames
    data = [n for (n, f, v) in self.returnPrco(prcotype)]
  File "/usr/lib/python2.6/site-packages/yum/packages.py", line 512, in <lambda>
    provides_names = property(fget=lambda self: self.returnPrcoNames('provides'))
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 173, in allowedMultipleInstalls
    for prov in po.provides_names:
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 3044, in install
    if not self.allowedMultipleInstalls(po):
  File "/usr/lib/python2.6/site-packages/yum/transactioninfo.py", line 248, in add
    for condtxmbr in self.install_method(po=pkg):
  File "/usr/lib/python2.6/site-packages/yum/transactioninfo.py", line 648, in add
    TransactionData.add(self, txmember)
  File "/usr/lib/anaconda/sortedtransaction.py", line 71, in add
    SortableTransactionData.add(self, txmember)
  File "/usr/lib/python2.6/site-packages/yum/transactioninfo.py", line 385, in addInstall
    self.add(txmbr)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 566, in _requiringFromTransaction
    txmbr = self.tsInfo.addInstall(best)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 260, in _processReq
    CheckDeps, missingdep = self._requiringFromTransaction(po, requirement, errormsgs)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 793, in _resolveRequires
    (checkdep, missing, errormsgs) = self._processReq(po, dep)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 691, in resolveDeps
    CheckDeps, checkinstalls, checkremoves, missing = self._resolveRequires(errors)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 862, in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/anaconda/yuminstall.py", line 1417, in doPostSelection
    (code, msgs) = self.ayum.buildTransaction()
  File "/usr/lib/anaconda/backend.py", line 290, in doPostSelection
    return anaconda.backend.doPostSelection(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1313, in nextClicked
    self.anaconda.dispatch.gotoNext()
KeyError: <yuminstall.AnacondaYumRepo object at 0x7f459004d7d0>

Comment 1 He Rui 2010-05-10 02:59:01 UTC
Created attachment 412702 [details]
Attached traceback automatically from anaconda.

Comment 2 He Rui 2010-05-10 03:35:00 UTC
Steps:

1. Use f13-final-rc2-boot.iso to install with default settings and advance to the repository step.

2. Add a local repo, select 'Customize Now', and click next to review the packages.

3. Click 'Back' to the repo step again, and deselect default mirror links. Only keep the added local repo checked.

4. Click 'next' and 'next' to install the packages.

5. Exception occurred. 

Note: if add a repo and deselect default mirror links directly or just use default links, this error doesn't occur.

Comment 3 Radek Vykydal 2010-05-10 08:54:25 UTC

*** This bug has been marked as a duplicate of bug 505189 ***


Note You need to log in before you can comment on or make changes to this bug.