Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 590519 - [1996196]can't suppress 'Input Method submenu ' in eclipse application
[1996196]can't suppress 'Input Method submenu ' in eclipse application
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: eclipse (Show other bugs)
5.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Andrew Overholt
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-09 23:10 EDT by Issue Tracker
Modified: 2012-01-18 10:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-18 10:45:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
disable im option as required (1.77 KB, patch)
2010-05-09 23:13 EDT, ritz
no flags Details | Diff

  None (edit)
Description Issue Tracker 2010-05-09 23:10:30 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2010-05-09 23:10:31 EDT
Event posted on 04-05-2010 02:47pm IST by ashishks

can't suppress 'Input Method submenu ' in eclipse application.

Setting gconf value for show_input_method_menu option as false does work for other gnome application like gnome-terminal, gedit, etc. This setting has no effect on eclipse.

gconftool-2 --type bool --set '/desktop/gnome/interface/show_input_method_menu' false


This event sent from IssueTracker by rkhadgar  [Support Engineering Group]
 issue 843493
Comment 2 Issue Tracker 2010-05-09 23:10:32 EDT
Event posted on 04-05-2010 02:56pm IST by ashishks

This issue is easily reproducible, Just install eclipse pacakges on RHEL5
 yum install eclipse*

Run eclipse application
 Application -> Programming -> Eclipse

Right click on Eclipse editor window and observe "Input Methods" option
at the bottom of menu.
This option is shown irrespective of show_input_method_menu gconf
setting.

I have attached sosreport and screenshot of problem screen.



Issue escalated to Support Engineering Group by: ashishks.
ashishks assigned to issue for Production Support (Pune).
Category set to: X Windows::Other
Internal Status set to 'Waiting on SEG'
Status set to: Waiting on Tech

This event sent from IssueTracker by rkhadgar  [Support Engineering Group]
 issue 843493
Comment 3 Issue Tracker 2010-05-09 23:10:33 EDT
Event posted on 06-05-2010 07:19pm IST by rkhadgar

__self: upstream - 
https://bugs.eclipse.org/bugs/show_bug.cgi?id=284777


This event sent from IssueTracker by rkhadgar  [Support Engineering Group]
 issue 843493
Comment 4 ritz 2010-05-09 23:13:02 EDT
Created attachment 412703 [details]
disable im option as required

note: patch does not accept space in filename/directory. I have used the below
to build rpm package.

Patch200: eclipse-gtk-im-menu-java.patch
Patch201: eclipse-gtk-im-os-java.patch 

pushd plugins/org.eclipse.swt/Eclipse\ SWT/gtk/org/eclipse/swt/widgets/
%patch200 -p0
popd

pushd plugins/org.eclipse.swt/Eclipse\ SWT\ PI/gtk/org/eclipse/swt/internal/gtk
%patch201
popd
Comment 5 Andrew Overholt 2010-05-17 08:31:22 EDT
I am not well-versed in GTK input methods.  If you say this is a bug and that it is fixed with these patches (which upstream seems okay with), we can apply them.
Comment 6 Chris Williams 2012-01-18 10:45:12 EST
It has been some time since this BZ was updated and both customer issues have been closed. Closing NOTABUG. Feel free to open a case with Red Hat Support if this is still an issue.

Note You need to log in before you can comment on or make changes to this bug.