Bug 590524 - [fix available] openoffice.org chart crash on inf values
Summary: [fix available] openoffice.org chart crash on inf values
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org (Show other bugs)
(Show other bugs)
Version: 5.5
Hardware: All Linux
low
medium
Target Milestone: ---
: ---
Assignee: Caolan McNamara
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-10 03:50 UTC by jmehl
Modified: 2011-08-03 09:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-03 09:05:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
text generated automatically (11.89 KB, application/octet-stream)
2010-05-10 03:50 UTC, jmehl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 111524 None None None Never

Description jmehl 2010-05-10 03:50:33 UTC
Created attachment 412705 [details]
text generated automatically

Description of problem:

openoffice.org spreadsheet crashed several times.  Each time text output to be submitted as a bug report was generated.

Version-Release number of selected component (if applicable):

openoffice.org-core-3.1.1-19.5.el
How reproducible:

It occurred at least 4 times; I have not tried to reproduce it.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Caolan McNamara 2010-05-10 07:55:55 UTC
You have nvidia video drivers installed, that always makes me suspicious as they have historically caused any number of odd problems, so I'd really prefer to have a reproducible route to re-create this crash. From the stack it appears to be on rendering an embedded chart. Is it possible to attach here the document with the embedded chart which is triggering this problem ? Or if not, to send it directly to me in private.

Comment 2 David Tardon 2010-05-10 08:47:31 UTC
I'm getting this stack when rotating a 3d chart. No crash yet, though.

dtardon->jmehl: What kind of chart did you manipulate?

Comment 3 jmehl 2010-05-10 15:29:17 UTC
Alas, I have not had time to narrow down the conditions where the bug occurs.  I was NOT directly manipulating a chart; certainly not rotating it.  However the spreadsheet I was working on had two XY-charts on the active sheet.  The data fields were solutions to a differential equation that got updated when I change parameters.  The plot then got updated.  I believe there were NANs in the data fields just before the crash.

Comment 4 Caolan McNamara 2010-05-10 19:10:10 UTC
Could you attach the spreadsheet here, even if its not crashing now, might give us something to work with to trigger it ourselves.

Comment 5 Caolan McNamara 2010-05-10 19:22:05 UTC
I see it now. Reproducible on x86_64

Comment 6 Caolan McNamara 2010-05-11 07:42:50 UTC
Submitted fix upstream, checked into devel.

Comment 8 RHEL Product and Program Management 2010-08-09 18:30:19 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 9 RHEL Product and Program Management 2011-01-11 20:49:42 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 10 RHEL Product and Program Management 2011-01-11 23:17:14 UTC
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Comment 11 RHEL Product and Program Management 2011-05-31 13:31:00 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 14 RHEL Product and Program Management 2011-08-03 09:05:23 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.