Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 590528 - bkr cannot be run (traceback: pkg_resources.DistributionNotFound: bkr.client==...)
bkr cannot be run (traceback: pkg_resources.DistributionNotFound: bkr.client=...
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: command line (Show other bugs)
0.5
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Bill Peck
: Reopened
: 592795 593996 602341 609248 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-10 01:08 EDT by Han Pingtian
Modified: 2010-08-12 22:05 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-11 23:21:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Han Pingtian 2010-05-10 01:08:20 EDT
Description of problem:
On my F12, when try to run bkr:

[hpt@localhost tier1]$ bkr --help
Traceback (most recent call last):
  File "/usr/bin/bkr", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2655, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 648, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: bkr.client==0.5.33

Version-Release number of selected component (if applicable):
beaker-client-0.5.33-0.el5.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 5 Marian Csontos 2010-05-17 03:10:33 EDT
*** Bug 592795 has been marked as a duplicate of this bug. ***
Comment 7 Marian Csontos 2010-05-20 06:42:18 EDT
*** Bug 593996 has been marked as a duplicate of this bug. ***
Comment 8 Bill Peck 2010-06-08 16:43:16 EDT
Closing this now.  Since we have proper repos without the need for rhts-release anymore.

If you found this bug and you still have issues follow the instructions here to install the beaker repo for your platform:

https://engineering.redhat.com/trac/rhat/wiki/BeakerUserGuide

And remove the rhts-release rpm from your system

rpm -e rhts-release
Comment 9 Marian Csontos 2010-06-30 01:45:51 EDT
*** Bug 609248 has been marked as a duplicate of this bug. ***
Comment 10 Marian Csontos 2010-07-29 05:49:20 EDT
*** Bug 602341 has been marked as a duplicate of this bug. ***
Comment 11 Gurhan Ozen 2010-08-11 09:23:59 EDT
I am reopening this bug..
Following the instructions on an F11 laptop, I get the following issue:

beaker-client-0.5.32-2.fc11.noarch from beaker has depsolving problems
  --> Missing Dependency: beaker is needed by package beaker-client-0.5.32-2.fc11.noarch (beaker)
Error: Missing Dependency: beaker is needed by package beaker-client-0.5.32-2.fc11.noarch (beaker)


i can't find beaker.rpm anywhere, thought it seemed like rhts repo had it in its metadata but the actual package didn't exist.

Yes, I did remove rhts-release, subsequently rhts repo as well.

Thanks.
Comment 12 Marian Csontos 2010-08-11 10:42:17 EDT
For sure F11 is not supported anymore.
Upgrade is recommended.
Comment 13 Gurhan Ozen 2010-08-11 20:32:23 EDT
(In reply to comment #12)
> For sure F11 is not supported anymore.
> Upgrade is recommended.    

Yes, I understand that. 
However, I was pointing to the fact that beaker-client package has a requires for beaker package which doesn't exist in beaker repo. At least for F11 , it doesn't.

I don't know if this is carried over to newer version, if it's not , then there is no issue, but if it's this should be fixed.

Thanks
Comment 14 Raymond Mancy 2010-08-11 23:21:48 EDT
Hi Gurzhan, from what I can tell it is in the F13 repo
Comment 15 Raymond Mancy 2010-08-12 22:05:04 EDT
As marian has pointed out, the F13 repo is just symlinked to el6. So there's a chance there may still be conflicts

Note You need to log in before you can comment on or make changes to this bug.