Bug 590536 - cannot submit a xml file to beaker
cannot submit a xml file to beaker
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.5
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-10 01:56 EDT by Han Pingtian
Modified: 2010-05-13 06:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-13 06:57:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the xml file (5.83 KB, text/xml)
2010-05-10 01:56 EDT, Han Pingtian
no flags Details
another xml cannot be submitted (6.96 KB, text/xml)
2010-05-13 05:16 EDT, Han Pingtian
no flags Details

  None (edit)
Description Han Pingtian 2010-05-10 01:56:40 EDT
Created attachment 412720 [details]
the xml file

Description of problem:
We have a xml file which can be submitted to RHTS, but cannot submit to beaker. We always get this error message:

<Fault 1: 'bkr.server.bexceptions.BX:u\'No Distro matches Recipe: <distroRequires><and><distro_arch op="=" value="x86_64"/><distro_family op="=" value="RedHatEnterpriseLinux6"/><distro_name op="=" value="RHEL6.0-20100428.3"/><distro_variant op="=" value="Server"/></and><distro_virt op="=" value="1"/></distroRequires>\''>



Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.bkr job-submit --convert default-kvm-guest.xml
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Peck 2010-05-10 10:03:56 EDT
Thanks for the bug report.  I have a fix for this which I'm testing.  I'm hoping to get this deployed live Today.  But it may not happen until Tomorrow.

I will update here when its pushed.
Comment 2 Han Pingtian 2010-05-13 04:49:22 EDT
We again have at least two xml files cannot submitted to beaker. The results are:

<Fault 1: 'bkr.server.bexceptions.BX:u\'No Distro matches Recipe: <distroRequires><and><distro_arch op="=" value="ppc"/><distro_name op="=" value="RHEL5-Server-U5"/><distro_family op="=" value="RedHatEnterpriseLinuxServer5"/></and><distro_virt op="=" value=""/></distroRequires>\''>

and

<Fault 1: 'bkr.server.bexceptions.BX:u\'No Distro matches Recipe: <distroRequires><and><distro_arch op="=" value="ppc"/><distro_name op="=" value="RHEL5-Server-U5"/><distro_family op="=" value="RedHatEnterpriseLinuxServer5"/></and><distro_virt op="=" value=""/></distroRequires>\''>

the same problem and has been resolved in the new package?
Comment 3 Han Pingtian 2010-05-13 05:16:15 EDT
Created attachment 413692 [details]
another xml cannot be submitted

The error message should be this:

<Fault 1: 'bkr.server.bexceptions.BX:u\'No Distro matches Recipe: <distroRequires><and><distro_arch op="=" value="ppc"/><distro_name op="=" value="RHEL5-Server-U5"/><distro_family op="=" value="RedHatEnterpriseLinuxServer5"/></and><distro_virt op="=" value=""/></distroRequires>\''>
Comment 4 Bill Peck 2010-05-13 06:57:48 EDT
Hello,

The problem you are reporting is different.  Legacy RHTS improperly called RHEL5 ppc and not ppc64.  In fact I had a bug in the old system about this.

In beaker because we use cobbler, the distro is imported correctly as ppc64.

see here. https://beaker.engineering.redhat.com/distros/?distrosearch-0.table=Name&distrosearch-0.operation=contains&distrosearch-0.value=RHEL5-Server-U5&distrosearch-1.table=Arch&distrosearch-1.operation=contains&distrosearch-1.value=ppc&Search=Search

Please change your xml to ppc64.  

This might be painful until we can remove the old workflows from the equation.

I'm closing this bz since the original problem is fixed.

Note You need to log in before you can comment on or make changes to this bug.