Bug 59054 - cannot open /dev/lp0
Summary: cannot open /dev/lp0
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-30 01:09 UTC by Need Real Name
Modified: 2007-04-18 16:39 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2002-02-05 22:59:48 UTC


Attachments (Terms of Use)
cannot open lp (273 bytes, text/plain)
2002-01-30 22:38 UTC, Need Real Name
no flags Details
insmod and rmmod errors (1.76 KB, text/plain)
2002-01-31 22:37 UTC, Need Real Name
no flags Details
rmmod (487 bytes, text/plain)
2002-02-01 01:41 UTC, Need Real Name
no flags Details

Description Need Real Name 2002-01-30 01:09:44 UTC
Description of Problem:
trying to print with my Epson 640 color printer. Have everything set up in
printing control panel. On start up when LPD starts get the error -new cannot
open LP device. '/dev/lp0' no such address or device. Checked and dev package is
installed, LP0 file exist. lp is installed, and I presume running. Been working
with ticket manager for over 30 days now. Reccomends reporting as a bug, since
they have no problems using the epson printer.

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Tim Waugh 2002-01-30 07:27:47 UTC
Please attach your /etc/modules.conf.

Also please try this and attach the resulting dmesg.out file:
1. Become root.
2. Run: dmesg -c > /dev/null
3. Run: rmmod lp
4. Run: rmmod parport_pc
5. Run: insmod parport_pc
6. Run: dmesg > dmesg.out

Also what are your BIOS settings for the on-board parallel port, presuming that
the parallel port you want to use is built in to the motherboard?


Comment 2 Need Real Name 2002-01-30 22:38:13 UTC
Created attachment 44056 [details]
cannot open lp

Comment 3 Need Real Name 2002-01-30 22:44:49 UTC
dmesg.out file was created, but has no contents, would not attach. Tried twice.
lp is not loaded, parport_pc is also not loaded, insmod parport_pc has error
when executed.

Hope this helps

Comment 4 Tim Waugh 2002-01-30 22:46:37 UTC
Well, what was the error message exactly?

Also, what about the BIOS?


Comment 5 Need Real Name 2002-01-30 22:52:23 UTC
BIOS settings for parallel port is set to auto and bidirectional

Comment 6 Tim Waugh 2002-01-31 08:38:39 UTC
And the error message?


Comment 7 Need Real Name 2002-01-31 22:37:52 UTC
Created attachment 44180 [details]
insmod and rmmod errors

Comment 8 Tim Waugh 2002-01-31 22:44:35 UTC
What format is that in?  It looks like gibberish!


Comment 9 Need Real Name 2002-02-01 01:41:34 UTC
Created attachment 44196 [details]
rmmod

Comment 10 Tim Waugh 2002-02-01 08:14:50 UTC
And after doing that, if you run 'dmesg', it displays nothing at all?


Comment 11 Need Real Name 2002-02-04 17:22:32 UTC
I did once, after running the command 3 or 4 times did get a message that I had 
mail in var/spool/root. looked weird to me, is this what I am looking for?

Comment 12 Tim Waugh 2002-02-04 17:36:20 UTC
No, it isn't.  Well, I guess there really aren't any kernel messages.  That
means that just couldn't find any port at 0x378, 0x278, 0x3bc, or on the PCI bus.

What base address does the BIOS say that the port should be at?

Comment 13 Need Real Name 2002-02-05 21:49:03 UTC
changed my bios from auto select for Parallel port to enabled to find the port
address. It is 0x378 and IRQ 7. Since I have made that change I nolonger get the
cannot open /dev/lp0 on the lp start up. Just a green "ok", which is good, but
still cannot print.

Comment 14 Tim Waugh 2002-02-05 22:59:42 UTC
Okay, BIOS configuration thing.  Closing.

As for still not being able to print, please check for other bugzilla entries
that may be relevant.  Also make sure that you upgrade to the latest errata
packages for printing.


Note You need to log in before you can comment on or make changes to this bug.