Bug 59062 - dependency problems not displayed correctly
dependency problems not displayed correctly
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2002-01-30 06:18 EST by Patrick C. F. Ernzer
Modified: 2015-01-07 18:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-05-22 08:45:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2002-01-30 06:18:01 EST
Description of Problem:
up2date does not display dependency problems correctly

Version-Release number of selected component (if applicable):

How Reproducible:

Steps to Reproduce:
try to update rpm from Skunkworks by issuing 'up2date rpm'

Actual Results:
[root@morn rhn-packages]# up2date rpm

Retrieving list of all available packages...
There was a package dependency problem.  The message was:
A package providing librpmdb-4.0.3.so could not be found.
A package providing librpm-4.0.3.so could not be found.
A package providing librpmio-4.0.3.so could not be found.
A package providing librpmbuild-4.0.3.so could not be found.

Expected Results:
librpm-4.0.3.so   is needed by gnorpm-0.96-11
librpm-4.0.3.so   is needed by kdeadmin-2.2.2-2
librpmbuild-4.0.3.so   is needed by kdeadmin-2.2.2-2
librpmdb-4.0.3.so   is needed by gnorpm-0.96-11
librpmdb-4.0.3.so   is needed by kdeadmin-2.2.2-2
librpmio-4.0.3.so   is needed by gnorpm-0.96-11
librpmio-4.0.3.so   is needed by kdeadmin-2.2.2-2

or even better something along the lines of:
you are attempting to install rpm-4.0.4-0.19, but the following packages require

Additional Information:
I set this to 'Red hat Beta' if you deem this too paranoid, remove the flag.
Comment 1 Adrian Likins 2002-02-11 16:05:24 EST
rawhide issue. 

you get both pieces ;->

Should be fixed in an upcoming rawhide snapshot, eventually.
Comment 2 Adrian Likins 2002-03-06 18:27:49 EST
btw, next version of the client will be more explicit and accurate
in the way it describes these kinds of dependency errors.
Comment 3 Matt Jamison 2003-05-22 08:45:42 EDT
works properly

closing bug.

Note You need to log in before you can comment on or make changes to this bug.