Bug 590627 - [abrt] crash in bash-4.0.35-3.fc12: Process /bin/bash was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in bash-4.0.35-3.fc12: Process /bin/bash was killed by signal 11...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bash
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Roman Rakus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8c1fda27406c9c1f24dc9d3f30e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-10 11:10 UTC by dr-ru
Modified: 2014-01-13 00:11 UTC (History)
2 users (show)

Fixed In Version: bash-4.0.35-4.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-06 17:31:38 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (108.77 KB, text/plain)
2010-05-10 11:10 UTC, dr-ru
no flags Details

Description dr-ru 2010-05-10 11:10:15 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /bin/bash
component: bash
crash_function: command_word_completion_function
executable: /bin/bash
global_uuid: 8c1fda27406c9c1f24dc9d3f30ee8ccc36dbcc13
kernel: 2.6.32.11-99.fc12.x86_64
package: bash-4.0.35-3.fc12
rating: 4
reason: Process /bin/bash was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1.There are a folder - /home/dimion/Загрузки/Torrents/Galakticheskaya_voyna_\[torrents.ru\]VIDEO_TS
2.I'm want to take the folder path by autocompletion, on last directory bash is crash

Comment 1 dr-ru 2010-05-10 11:10:25 UTC
Created attachment 412801 [details]
File: backtrace

Comment 2 Roman Rakus 2010-05-20 11:31:22 UTC
Are you using bash-completion package? What does `rpm -q bash-completion' return?

Comment 3 dr-ru 2010-05-20 15:27:07 UTC
(In reply to comment #2)
> Are you using bash-completion package? What does `rpm -q bash-completion'
> return?    

`rpm -q bash-completion' is return - not installed

Comment 4 Roman Rakus 2010-05-21 14:20:26 UTC
I can't reproduce it. Is it 100% reproducible for you? Maybe it needs some special conditions; can you please write step-by-step what you use for autocompletion? (In which dir you are, what you are typing..)

Comment 5 Roman Rakus 2010-05-21 14:21:51 UTC
But, rpm -q bash-completion should return something like package bash-completion is not installed.
Please run directly this:
rpm -q bash-completion

Comment 6 dr-ru 2010-05-21 15:32:41 UTC
(In reply to comment #5)
> But, rpm -q bash-completion should return something like package
> bash-completion is not installed.
> Please run directly this:
> rpm -q bash-completion    

My system locale is Russia, so i think, you do not read the russian text message :). Sorry for bad English. I'm check the bash-completion package - is not installed.

Comment 7 dr-ru 2010-05-21 15:38:52 UTC
(In reply to comment #4)
> I can't reproduce it. Is it 100% reproducible for you? Maybe it needs some
> special conditions; can you please write step-by-step what you use for
> autocompletion? (In which dir you are, what you are typing..)    

Step by step:
1. cd /home/dimion/
2. type /h and TAB - > appearing /home/
3. type d and TAB - > appearing /home/dimion/
4. type З (in Russian) and TAB - > appearing /home/dimion/Загрузки/
5. type T and TAB - >  appearing /home/dimion/Загрузки/Torrents/
6. type G and TAB - > appearing /home/dimion/Загрузки/Torrents/Galakticheskaya_voyna_\[torrents.ru\]/
7. type V and TAB -> bash is crash

Comment 8 dr-ru 2010-05-21 15:45:12 UTC
(In reply to comment #7)
> (In reply to comment #4)
> > I can't reproduce it. Is it 100% reproducible for you? Maybe it needs some
> > special conditions; can you please write step-by-step what you use for
> > autocompletion? (In which dir you are, what you are typing..)    
> 
> Step by step:
> 1. cd /home/dimion/
> 2. type /h and TAB - > appearing /home/
> 3. type d and TAB - > appearing /home/dimion/
> 4. type З (in Russian) and TAB - > appearing /home/dimion/Загрузки/
> 5. type T and TAB - >  appearing /home/dimion/Загрузки/Torrents/
> 6. type G and TAB - > appearing
> /home/dimion/Загрузки/Torrents/Galakticheskaya_voyna_\[torrents.ru\]/
> 7. type V and TAB -> bash is crash    

Reproduced with 100%, also current directory is not importance

Comment 9 Roman Rakus 2010-05-21 16:13:27 UTC
Yep, now I can reproduce it. Thanks for your step by step reproducer and let me investigate it.

Comment 10 Fedora Update System 2010-05-21 17:07:13 UTC
bash-4.0.35-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/bash-4.0.35-4.fc12

Comment 11 Fedora Update System 2010-05-24 19:41:07 UTC
bash-4.0.35-4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bash'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/bash-4.0.35-4.fc12

Comment 12 Fedora Update System 2010-07-06 17:31:34 UTC
bash-4.0.35-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.