Bug 590628 - Pagination breaks with new python-routes
Summary: Pagination breaks with new python-routes
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-webhelpers (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Kyle VanderBeek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-10 11:12 UTC by Nils Philippsen
Modified: 2010-08-17 18:54 UTC (History)
2 users (show)

Fixed In Version: python-webhelpers-1.0-0.1.b6.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 05:34:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback (6.76 KB, text/plain)
2010-05-10 11:12 UTC, Nils Philippsen
no flags Details

Description Nils Philippsen 2010-05-10 11:12:35 UTC
Created attachment 412802 [details]
traceback

Description of problem:
There have been a number of updates in the TurboGears2/pylons stack lately and with these, pagination doesn't work anymore but throws tracebacks.

Version-Release number of selected component (if applicable):
python-webhelpers-0.6.4-4.fc12.noarch
python-routes-1.12.1-1.fc13.noarch
python-pylons-0.9.7-2.fc12.noarch
TurboGears2-2.1-0.1.b2.fc13.noarch

How reproducible:
Reproducible.

Steps to Reproduce:
1. Update to the new versions in F-13.
2. Generate a page with pagination (the template must render the pagination links; I e.g. don't render them if all items fit on one page).
  
Actual results:
Supposedly when generating the pagination links ("<< < 1 ... 7 8 9 ... 15 > >>"), the template generation throws a traceback (attached). Without debugging enabled, the page returns with in error 500.

Expected results:
No traceback, page rendered properly.

Additional info:
This is the template snippet which eventually renders the pagination links:

  <span py:strip="True" py:if="len(events_per_year) > 0" py:with="pager=current_page.pager('$link_first $link_previous ~3~ $link_next $link_last')">

- events_per_year is a dict of events that happen in one calendar year (think of a "news" page
- current_page is:

      current_page = paginate.Page(events, page,
                items_per_page=self.items_per_page)

PS: I'll be on vacation for the next two weeks, with no or only spotty net access.

Comment 1 Luke Macken 2010-05-10 18:59:48 UTC
Looks like we need a newer WebHelpers.

Comment 2 Fedora Update System 2010-05-10 20:43:19 UTC
python-webhelpers-1.0-0.1.b6.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/python-webhelpers-1.0-0.1.b6.fc12

Comment 3 Fedora Update System 2010-05-10 20:43:23 UTC
python-webhelpers-1.0-0.1.b6.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/python-webhelpers-1.0-0.1.b6.fc13

Comment 4 Fedora Update System 2010-05-10 20:43:27 UTC
python-webhelpers-1.0-0.1.b6.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/python-webhelpers-1.0-0.1.b6.el5

Comment 5 Fedora Update System 2010-05-10 21:51:35 UTC
python-webhelpers-1.0-0.1.b6.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-webhelpers'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/python-webhelpers-1.0-0.1.b6.fc13

Comment 6 Fedora Update System 2010-05-11 19:39:12 UTC
python-webhelpers-1.0-0.1.b6.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-webhelpers'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/python-webhelpers-1.0-0.1.b6.fc12

Comment 7 Fedora Update System 2010-05-12 01:51:55 UTC
python-webhelpers-1.0-0.1.b6.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-webhelpers'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/python-webhelpers-1.0-0.1.b6.el5

Comment 8 Nils Philippsen 2010-05-12 09:11:49 UTC
Thanks for the quick response, it works for me.

Comment 9 Fedora Update System 2010-08-17 05:34:04 UTC
python-webhelpers-1.0-0.1.b6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-08-17 05:40:12 UTC
python-webhelpers-1.0-0.1.b6.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-08-17 18:54:34 UTC
python-webhelpers-1.0-0.1.b6.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.