Bug 590643 - Expression parsing improvements: 23x FAIL gdb.cp/realcpp.exp
Expression parsing improvements: 23x FAIL gdb.cp/realcpp.exp
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdb (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jan Kratochvil
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-10 08:01 EDT by Petr Muller
Modified: 2016-09-19 22:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-11 15:26:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Muller 2010-05-10 08:01:32 EDT
Description of problem:
gdb.cp/realcpp.exp was suggested to be run as part of
'Expression Parsing Improvements' feature testing for RHEL6. This testcase has
23 failures across all architectures:

Running ./gdb.cp/realcpp.exp ...
FAIL: gdb.cp/realcpp.exp: print policyd<base>::policyd
FAIL: gdb.cp/realcpp.exp: print policyd<char>::policyd
FAIL: gdb.cp/realcpp.exp: print policyd<int>::policyd
FAIL: gdb.cp/realcpp.exp: print policyd<long>::policyd
FAIL: gdb.cp/realcpp.exp: print policyd<tclass<int> >::policyd
FAIL: gdb.cp/realcpp.exp: list base::overload(void)
FAIL: gdb.cp/realcpp.exp: list policyd<base>::policyd
FAIL: gdb.cp/realcpp.exp: list policyd<char>::policyd
FAIL: gdb.cp/realcpp.exp: list policyd<int>::policyd
FAIL: gdb.cp/realcpp.exp: list policyd<long>::policyd
FAIL: gdb.cp/realcpp.exp: list policyd<tclass<int> >::policyd
FAIL: gdb.cp/realcpp.exp: setting breakpoint at base::overload(void)
FAIL: gdb.cp/realcpp.exp: continue to base::overload(void)
FAIL: gdb.cp/realcpp.exp: setting breakpoint at policyd<base>::policyd
FAIL: gdb.cp/realcpp.exp: continue to policyd<base>::policyd
FAIL: gdb.cp/realcpp.exp: setting breakpoint at policyd<char>::policyd
FAIL: gdb.cp/realcpp.exp: continue to policyd<char>::policyd
FAIL: gdb.cp/realcpp.exp: setting breakpoint at policyd<int>::policyd
FAIL: gdb.cp/realcpp.exp: continue to policyd<int>::policyd
FAIL: gdb.cp/realcpp.exp: setting breakpoint at policyd<long>::policyd
FAIL: gdb.cp/realcpp.exp: continue to policyd<long>::policyd
FAIL: gdb.cp/realcpp.exp: setting breakpoint at policyd<tclass<int> >::policyd
FAIL: gdb.cp/realcpp.exp: continue to policyd<tclass<int> >::policyd

Version-Release number of selected component (if applicable):
gdb-7.1-18

How reproducible:
always

Steps to Reproduce:
1. runtest --tool=gdb gdb.cp/realcpp.ex
2.
3.
  
Actual results:
# of expected passes            376
# of unexpected failures        23

Expected results:
# of expected passes            399

Additional info:
Comment 1 RHEL Product and Program Management 2010-05-10 09:24:18 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Jan Kratochvil 2010-05-11 15:02:43 EDT
Hi Keith, I believe you should be aware of it - do you agree with these FAILures?
Comment 4 Keith Seitz 2010-05-11 15:13:20 EDT
Yes, this is expected. IMO, we should retire realecpp.exp in favor of the upstream cpexprs.exp (which is probably already included).

realcpp and cpexprs are essentially identical; the failing default template tests -- 20 of the failures in realcpp -- are not included in cpexprs.exp because there is no way to fix them today. That leaves the three known failures (which I believe can be fixed) which also occur in realcpp: "print"/"list"/"break" & "continue" to base::overload(void) [which is declared const, but gdb doesn't recognize that].
Comment 5 Jan Kratochvil 2010-05-11 15:26:40 EDT
Therefore closing as known FAILs which are common in GDB.

Note You need to log in before you can comment on or make changes to this bug.