Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 590669 - gdm-restart does nothing, no indication which tool replaces it
gdm-restart does nothing, no indication which tool replaces it
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: jmccann
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-10 09:06 EDT by Matthias Schroder
Modified: 2015-01-14 18:25 EST (History)
5 users (show)

See Also:
Fixed In Version: gdm-2.30.4-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:27:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Schroder 2010-05-10 09:06:11 EDT
Description of problem: gdm-restart does nothing, but I have not found any information concerning a possible replacement.


Version-Release number of selected component (if applicable): gdm-2.28.2-5.el6


How reproducible: 100%


Steps to Reproduce:
1. run gdm-restart
2.
3.
  
Actual results: 
output: "Not supported"

Expected results: X11 restarted


Additional info: the script has been deprived off all functionality, it just spits out 'Not supported'. I can't find any hint indicating which tool is supposed to replace gdm-restart. Either a man page should be added, or gdm-restart should tell the user which tool to use instead.
Comment 2 RHEL Product and Program Management 2010-05-10 10:32:13 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 jmccann 2010-06-02 17:55:31 EDT
There isn't a replacement.  That script was retained (perhaps mistakenly) in order so that scripts and spec files wouldn't break.  GDM is the parent process for every user login session and can't really be restarted simply.

Changing the behavior and output of the script at this point would be inconsistent with the reasons for the its existence - and mean we should just remove it.

I'd prefer to remove it.
Comment 4 jmccann 2010-06-04 12:31:03 EDT
I have spec file fix ready to commit to remove the obsolete utilities.  Just need a rhel6 flag it seems.
Comment 5 Cameron Meadors 2010-06-04 13:57:42 EDT
I want to make sure I understand this.  gdm-restart is being removed because you should not restart gdm because it would kill all sessions.  Is that correct?  My only use case for ever using gdm-restart directly was when testing gdm or when X hung and I needed to get back to a gdm greeter easily.  Is simply killing gdm the equivelent now?  I know this is a corner case but just want to make sure I understand the consequences of removing gdm-restart. It was also implied that other scripts used gdm-restart.  What were those and why do they not need that utility anymore.
Comment 6 jmccann 2010-06-04 14:22:44 EDT
gdm-restart has been a no-op for quite a few Fedora releases now.  We kept it around mostly because we were lazy and didn't want to check for spec files that used it.  The gdm.spec uses it.  But there is value in not supporting commands that do nothing (or worse, confuse) in RHEL I think.

Simply killing gdm should cause it to be restarted, yes.  This is in the domain of the init system.  The init system is responsible for keeping services like this running.  If you want to stop the gdm service altogether you can do something like init 3 (or maybe there is some other upstart command).
Comment 7 Christopher Aillon 2010-06-04 19:01:25 EDT
(In reply to comment #6)
> gdm-restart has been a no-op for quite a few Fedora releases now.  We kept it
> around mostly because we were lazy and didn't want to check for spec files that
> used it.  The gdm.spec uses it.

Just to clarify, is gdm.spec is the only place this is currently used?
Comment 9 Ray Strode [halfline] 2010-06-29 15:24:36 EDT
This should be fixed now (although I forgot to mention it in the changelog)
Comment 12 releng-rhel@redhat.com 2010-11-10 15:27:39 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.