Bug 590683 - Missing dependency on DevKit-disks
Summary: Missing dependency on DevKit-disks
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bltk   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jiri Skala
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-10 13:27 UTC by Radek Vokal
Modified: 2014-11-09 22:32 UTC (History)
6 users (show)

Fixed In Version: bltk-1.0.9-12.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 19:56:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Radek Vokal 2010-05-10 13:27:58 UTC
Description of problem:
bltk -I should require DeviceKit-disks

it reports 

/usr/lib/bltk/bin/bltk_get_hdparm: line 64: /usr/bin/devkit-disks: No such file or directory


Version-Release number of selected component (if applicable):
bltk-1.0.9-9.el6.i686

Comment 1 RHEL Product and Program Management 2010-05-10 14:32:02 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Jiri Koten 2010-05-25 16:11:39 UTC
NOT fixed in bltk-1.0.9-11.el6.x86_64

$ bltk -I
...
/usr/lib64/bltk/bin/bltk_get_hdparm: line 64: /usr/bin/devkit-disks: No such file or directory
grep: /home/test/.bltk/tmp/dev_info: No such file or directory
grep: /home/test/.bltk/tmp/dev_info: No such file or directory

DeviceKit-disks was replaced by udisks but there is no devkit-disks command in this package.

Comment 5 Jiri Skala 2010-05-26 07:59:43 UTC
This is due to removing symlink 'devkit-disks' from udisks package in RHEL6. Fedora contains this symlink all the time. Therefore I'd like to ask for the reason removing mentioned symlink.

David why was the symlink removed while Fedora contains it?

Comment 6 Matthias Clasen 2010-05-27 13:09:18 UTC
The symlink was removed because the package was renamed to udisks, and the binaries were renamed along with it. It was removed in RHEL first, because we don't want to be stuck with it for 7+ years here, but it will be going away in Fedora soon, too.

Please change your script to use /usr/bin/udisks directly

Comment 8 Jiri Koten 2010-06-01 16:00:15 UTC
Bug fix verified with bltk-1.0.9-12.el6.

Comment 9 releng-rhel@redhat.com 2010-11-10 19:56:56 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.