Bug 590709 - Nagios uninstall by update
Summary: Nagios uninstall by update
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nagios   
(Show other bugs)
Version: 12
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-10 14:28 UTC by marianne@tuxette.fr
Modified: 2010-06-23 22:12 UTC (History)
7 users (show)

Fixed In Version: nagios-plugins-1.4.14-4.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-16 17:40:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Extract of the /var/log/messages (6.65 KB, text/plain)
2010-05-10 14:28 UTC, marianne@tuxette.fr
no flags Details

Description marianne@tuxette.fr 2010-05-10 14:28:05 UTC
Created attachment 412855 [details]
Extract of the /var/log/messages

Description of problem:
I've updated my desktop in wich I've installed a nagios server. 
The update have updated a lot of nagios-plugins and installed nagios-common but uninstall the nagios package

Version-Release number of selected component (if applicable):
 nagios-common-3.2.1-2.fc12.i686
nagios-3.2.1-2.fc12.i686

How reproducible:
updating a existant nagios install

  
Actual results:
all config files have been passed as "rpmsave" so no configuration is lost but it's very unexepected and deceiptful to see the QA fails 

I have reinstalled the nagios package and move the configfiles from .cfg.rpmsave to cfg and my nagios work again

Comment 1 Fedora Update System 2010-05-17 18:58:22 UTC
nagios-3.2.1-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/nagios-3.2.1-3.fc12

Comment 2 Fedora Update System 2010-05-17 18:58:27 UTC
nagios-3.2.1-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/nagios-3.2.1-3.fc11

Comment 3 Fedora Update System 2010-05-17 18:58:33 UTC
nagios-3.2.1-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/nagios-3.2.1-3.fc13

Comment 4 Fedora Update System 2010-05-18 07:40:07 UTC
nagios-plugins-1.4.14-4.el5,nagios-2.12-8.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/nagios-plugins-1.4.14-4.el5,nagios-2.12-8.el5

Comment 5 Fedora Update System 2010-05-18 07:40:24 UTC
nagios-plugins-1.4.14-4.el4,nagios-2.12-8.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/nagios-plugins-1.4.14-4.el4,nagios-2.12-8.el4

Comment 6 Fedora Update System 2010-05-19 02:38:50 UTC
nagios-plugins-1.4.14-4.el4, nagios-2.12-8.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nagios-plugins nagios'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/nagios-plugins-1.4.14-4.el4,nagios-2.12-8.el4

Comment 7 Fedora Update System 2010-05-19 02:39:40 UTC
nagios-plugins-1.4.14-4.el5, nagios-2.12-8.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nagios-plugins nagios'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/nagios-plugins-1.4.14-4.el5,nagios-2.12-8.el5

Comment 8 Michael Schwendt 2010-05-19 05:13:13 UTC
Both "Obsoletes" are wrong and should be removed. They are useless.

http://lists.fedoraproject.org/pipermail/devel/2010-May/136433.html

Btw, the damage is done. Where "nagios" was replaced by "nagios-common" due to the unneeded Obsoletes, you cannot make the update reinstall "nagios" unless you would make it a new dependency again [somewhere in a -plugin package].


> it's very unexepected and deceiptful to see the QA fails 

Which QA? That update hasn't seen any:

https://admin.fedoraproject.org/updates/nagios-plugins-1.4.14-3.fc12.1,nagios-3.2.1-2.fc12

Comment 9 Peter Lemenkov 2010-05-19 10:41:12 UTC
(In reply to comment #8)
> Both "Obsoletes" are wrong and should be removed. They are useless.

That's not true. In every case we splitting package, we must add Obsoletes to each new package, created from previous monolithic one. Otherwise user could face rpm conflicts or we'll create other rpm-related problems (for example, multiple owned directories).

My only (and very severe) mistake was that I didn't add necessary Obsoletes to both packages but only to nagios-common. Now I fixed this issue.

Comment 10 Michael Schwendt 2010-05-19 12:44:34 UTC
> In every case we splitting package, we must add Obsoletes to
> each new package, created from previous monolithic one.

Not true.

And certainly not true for this nagios --> nagios + nagios-common split either.

Comment 11 Peter Lemenkov 2010-05-19 13:05:16 UTC
(In reply to comment #10)
> > In every case we splitting package, we must add Obsoletes to
> > each new package, created from previous monolithic one.
> 
> Not true.
> 
> And certainly not true for this nagios --> nagios + nagios-common split either.    

Ok, to be more specific - here is a user's case:

1. User installs nagios (previous monolithic version).
2. User installs nagios-plugins (updated package) - this pulls nagios-common (newest version).

This leads to 'multiple owned directory' issue (because there is no way to tell user that nagios-common now owns directory previously owned by nagios). But if we'll use 'Obsoletes', then this update replaces nagios, thus all directories would have the only owner.

That's why we need 'Obsoletes' in nagios-common => We must add 'Obsoletes' to main nagios package to prevent issues like this one, described in the comment #0.

Comment 12 Michael Schwendt 2010-05-19 14:19:02 UTC
> That's why we need 'Obsoletes' in nagios-common

You didn't prove why you need that. The Obsoletes in nagios-common did nothing else than cause the breakage as described in this ticket.


> here is a user's case:

A simple "yum update" prior to adding new packages is common practise. It would pull in the updated nagios package *and* nagios-common.

In case there really were a file conflict that would error out at the transaction check (there's isn't, because just the dirs moved), self-Obsoletes in "nagios" would suffice and enforce an update of nagios. => That means, to _move_ the 'Obsoletes' from nagios-common to nagios, but not to put the same 'Obsoletes' into both packages.

Comment 13 Michael Schwendt 2010-05-19 14:40:49 UTC
$ rpm -q nagios
nagios-3.2.1-1.fc12.i686

$ sudo yum install nagios-plugins-load
...
Dependencies Resolved

================================================================================
 Package                 Arch     Version             Repository           Size
================================================================================
Installing:
 nagios-common           i686     3.2.1-3.fc12        updates-testing      13 k
     replacing  nagios.i686 3.2.1-1.fc12
 nagios-plugins-load     i686     1.4.14-3.fc12.1     updates              22 k
Installing for dependencies:
 nagios-plugins          i686     1.4.14-3.fc12.1     updates             164 k

Transaction Summary
================================================================================
Install       3 Package(s)
Upgrade       0 Package(s)

Total size: 199 k
Is this ok [y/N]: n

Certainly not okay, since it would also erase (= replace) nagios, which is what this bug report is about.

Comment 14 Fedora Update System 2010-06-09 09:30:44 UTC
nagios-3.2.1-5.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/nagios-3.2.1-5.fc12

Comment 15 Fedora Update System 2010-06-09 09:30:51 UTC
nagios-3.2.1-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/nagios-3.2.1-5.fc13

Comment 16 Fedora Update System 2010-06-09 09:30:55 UTC
nagios-3.2.1-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/nagios-3.2.1-5.fc11

Comment 17 Fedora Update System 2010-06-09 09:39:26 UTC
nagios-plugins-1.4.14-4.el5,nagios-2.12-9.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/nagios-plugins-1.4.14-4.el5,nagios-2.12-9.el5

Comment 18 Fedora Update System 2010-06-09 09:39:51 UTC
nagios-plugins-1.4.14-4.el4,nagios-2.12-9.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/nagios-plugins-1.4.14-4.el4,nagios-2.12-9.el4

Comment 19 Fedora Update System 2010-06-09 15:47:21 UTC
nagios-plugins-1.4.14-4.el4, nagios-2.12-9.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nagios-plugins nagios'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/nagios-plugins-1.4.14-4.el4,nagios-2.12-9.el4

Comment 20 Fedora Update System 2010-06-09 15:49:47 UTC
nagios-plugins-1.4.14-4.el5, nagios-2.12-9.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nagios-plugins nagios'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/nagios-plugins-1.4.14-4.el5,nagios-2.12-9.el5

Comment 21 Fedora Update System 2010-06-10 19:12:51 UTC
nagios-3.2.1-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nagios'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/nagios-3.2.1-5.fc11

Comment 22 Fedora Update System 2010-06-10 19:17:15 UTC
nagios-3.2.1-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nagios'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/nagios-3.2.1-5.fc13

Comment 23 Fedora Update System 2010-06-10 19:19:30 UTC
nagios-3.2.1-5.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nagios'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/nagios-3.2.1-5.fc12

Comment 24 Fedora Update System 2010-06-16 17:40:15 UTC
nagios-3.2.1-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2010-06-16 17:47:02 UTC
nagios-3.2.1-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2010-06-16 17:49:40 UTC
nagios-3.2.1-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2010-06-23 22:10:08 UTC
nagios-plugins-1.4.14-4.el4, nagios-2.12-9.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 28 Fedora Update System 2010-06-23 22:11:41 UTC
nagios-plugins-1.4.14-4.el5, nagios-2.12-9.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.