Bug 590717 - [abrt] crash in thunderbird-3.0.4-1.fc12: Process /usr/lib/thunderbird-3.0/thunderbird-bin was killed by signal 11 (SIGSEGV)
[abrt] crash in thunderbird-3.0.4-1.fc12: Process /usr/lib/thunderbird-3.0/th...
Status: CLOSED DUPLICATE of bug 571798
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
abrt_hash:913887f681ab60f74c24698ce5f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-10 10:37 EDT by Eric Blake
Modified: 2018-04-11 09:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-25 06:14:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (71.21 KB, text/plain)
2010-05-10 10:37 EDT, Eric Blake
no flags Details

  None (edit)
Description Eric Blake 2010-05-10 10:37:13 EDT
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/thunderbird-3.0/thunderbird-bin
comment: I just started thunderbird after a weekend of no connection; the crash appears to have happened while one thread was downloading over 200 messages from an IMAP folder and another thread was simultaneously trying to filter those messages into local folders.
component: thunderbird
crash_function: nsProfileLock::FatalSignalHandler
executable: /usr/lib/thunderbird-3.0/thunderbird-bin
global_uuid: 913887f681ab60f74c24698ce5fba8e8f821cd3e
kernel: 2.6.32.11-99.fc12.i686
package: thunderbird-3.0.4-1.fc12
rating: 4
reason: Process /usr/lib/thunderbird-3.0/thunderbird-bin was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)
Comment 1 Eric Blake 2010-05-10 10:37:15 EDT
Created attachment 412859 [details]
File: backtrace
Comment 2 Karel Klíč 2010-05-25 06:14:21 EDT

*** This bug has been marked as a duplicate of bug 571798 ***
Comment 3 Karel Klíč 2010-05-25 06:14:21 EDT
This bug appears to have been filled using a buggy version of ABRT, because
it contains a backtrace which is a duplicate of backtrace from bug #571798.

Sorry for the inconvenience.
Comment 4 Matěj Cepl 2010-07-25 08:59:45 EDT
#3  <signal handler called>
No symbol table info available.
#4  nsMsgSearchOfflineMail::ProcessSearchTerm (msgToMatch=0x0, aTerm=
    0xa9aed220, defaultCharset=0xaf34a208 "ISO-8859-1", scope=0xaa3cb2b0, db=
    0xab834040, headers=0x0, headerSize=0, Filtering=1, pResult=0xbfd149a0)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/base/search/src/nsMsgLocalSearch.cpp:457
        err = 0
        ccList = {<nsACString_internal> = {mData = 0x6528dc "", mLength = 0, 
            mFlags = 1}, <No data fields>}
        msgCharset = {<nsACString_internal> = {mData = 0x6528dc "", mLength = 
    0, mFlags = 1}, <No data fields>}
        matchAll = 0
        recipients = {<nsACString_internal> = {mData = 0x6528dc "", mLength = 
    0, mFlags = 1}, <No data fields>}
        charset = <value optimized out>
        charsetOverride = 0
        attrib = <value optimized out>
        matchString = {<nsACString_internal> = {mData = 0x6528dc "", 
            mLength = 0, mFlags = 1}, <No data fields>}
        msgFlags = <value optimized out>
        result = <value optimized out>
#5  0x0893910e in nsMsgSearchBoolExpression::OfflineEvaluate (this=
    0xa9f508a0, msgToMatch=0x0, defaultCharset=0xaf34a208 "ISO-8859-1", scope=
    0xaa3cb2b0, db=0xab834040, headers=0x0, headerSize=0, Filtering=1)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/base/search/src/nsMsgLocalSearch.cpp:171
        result = 0
#6  0x08939508 in nsMsgSearchOfflineMail::MatchTerms (msgToMatch=0x0, 
    termList=0xaa197b00, defaultCharset=0xaf34a208 "ISO-8859-1", scope=
    0xaa3cb2b0, db=0xab834040, headers=0x0, headerSize=0, Filtering=1, 
    aExpressionTree=0xaa0f46f0, pResult=0xbfd14af0)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/base/search/src/nsMsgLocalSearch.cpp:719
        err = <value optimized out>
#7  0x089398ed in nsMsgSearchOfflineMail::MatchTermsForFilter (msgToMatch=
    0x0, termList=0xaa197b00, defaultCharset=0xaf34a208 "ISO-8859-1", scope=
    0xaa3cb2b0, db=0xab834040, headers=0x0, headerSize=0, aExpressionTree=
    0xaa0f46f0, pResult=0xbfd14af0)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/base/search/src/nsMsgLocalSearch.cpp:348
No locals.
#8  0x08931daa in nsMsgFilter::MatchHdr (this=0xaa0f4660, msgHdr=0x0, folder=
    0xab88f020, db=0xab834040, headers=0x0, headersSize=0, pResult=0xbfd14af0)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/base/search/src/nsMsgFilter.cpp:641
        folderCharset = {<nsACString_internal> = {mData = 
    0xaf34a208 "ISO-8859-1", mLength = 10, mFlags = 5}, <No data fields>}
        rv = 2853127776
#9  0x0892f0f5 in nsMsgFilterList::ApplyFiltersToHdr (this=0xa9cfeab0, 
    filterType=1, msgHdr=0x0, folder=0xab88f020, db=0xab834040, headers=0x0, 
    headersSize=0, listener=0xab88f13c, msgWindow=0x0, aMessageFile=0x0)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/base/search/src/nsMsgFilterList.cpp:354
        matchTermStatus = 0
        result = 143422613
        isEnabled = 1
        curFilterType = 17
        filterIndex = 0
        filter = {<nsCOMPtr_base> = {mRawPtr = 0xaa0f4660}, <No data fields>}
        filterCount = 35
        rv = 0
        scope = 0xaa3cb2b0
#10 0x089e0788 in nsImapMailFolder::NormalEndMsgWriteStream (this=0xab88f000,

Note You need to log in before you can comment on or make changes to this bug.