Bug 59074 - Kernel sources does't recompile (2.4.x)
Kernel sources does't recompile (2.4.x)
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-30 11:09 EST by Need Real Name
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-31 07:54:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-30 11:09:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:0.9.7) Gecko/20011226

Description of problem:
I can't recompile the kernel sources 2.4.x for tar downloaded at www.kernel.org.

The first compilation is good, anche kernel works, but if I try to recompile the
kernel I got these messages:
gcc -D__KERNEL__ -I/usr/src/linux/include -Wall -Wstrict-prototypes
-Wno-trigraphs -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common -pipe
-mpreferred-stack-boundary=2 -march=i686   -c -o init/main.o init/main.c
In file included from /usr/src/linux/include/asm/semaphore.h:39,
                 from /usr/src/linux/include/linux/fs.h:199,
                 from /usr/src/linux/include/linux/capability.h:17,
                 from /usr/src/linux/include/linux/binfmts.h:5,
                 from /usr/src/linux/include/linux/sched.h:9,
                 from /usr/src/linux/include/linux/mm.h:4,
                 from /usr/src/linux/include/linux/slab.h:14,
                 from /usr/src/linux/include/linux/proc_fs.h:5,
                 from init/main.c:15:
/usr/src/linux/include/asm/system.h:13: parse error before `('
In file included from /usr/src/linux/include/linux/rwsem.h:27,
                 from /usr/src/linux/include/asm/semaphore.h:42,
                 from /usr/src/linux/include/linux/fs.h:199,
                 from /usr/src/linux/include/linux/capability.h:17,
                 from /usr/src/linux/include/linux/binfmts.h:5,
                 from /usr/src/linux/include/linux/sched.h:9,
                 from /usr/src/linux/include/linux/mm.h:4,
ecc ecc ecc ecc....

I read on kernel mailing list that is a problem of gcc distibuited by Red Hat...

This are rpms installed on my pc:

gcc-2.96-98
glibc-common-2.2.4-19.3
compat-egcs-6.2-1.1.2.16
compat-egcs-c++-6.2-1.1.2.16
compat-glibc-6.2-2.1.3.2
compat-libstdc++-6.2-2.9.0.16

I update my system regularry with up2date.

P.S. I try make clean && make dep && make bzImage or make oldconf && make
menuconfig && make ecc ecc.... 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Compile kernel source 2.4.x from www.kernel.org
2.Try to recompile the kernel
3.
	

Actual Results:  gcc -D__KERNEL__ -I/usr/src/linux/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fomit-frame-pointer -fno-strict-aliasing
-fno-common -pipe -mpreferred-stack-boundary=2 -march=i686   -c -o init/main.o
init/main.c
In file included from /usr/src/linux/include/asm/semaphore.h:39,
                 from /usr/src/linux/include/linux/fs.h:199,
                 from /usr/src/linux/include/linux/capability.h:17,
                 from /usr/src/linux/include/linux/binfmts.h:5,
                 from /usr/src/linux/include/linux/sched.h:9,
                 from /usr/src/linux/include/linux/mm.h:4,
                 from /usr/src/linux/include/linux/slab.h:14,
                 from /usr/src/linux/include/linux/proc_fs.h:5,
                 from init/main.c:15:
/usr/src/linux/include/asm/system.h:13: parse error before `('
In file included from /usr/src/linux/include/linux/rwsem.h:27,
                 from /usr/src/linux/include/asm/semaphore.h:42,
                 from /usr/src/linux/include/linux/fs.h:199,
                 from /usr/src/linux/include/linux/capability.h:17,
                 from /usr/src/linux/include/linux/binfmts.h:5,
                 from /usr/src/linux/include/linux/sched.h:9,
                 from /usr/src/linux/include/linux/mm.h:4,
                 from /usr/src/linux/include/linux/slab.h:14,
                 from /usr/src/linux/include/linux/proc_fs.h:5,
                 from init/main.c:15:
/usr/src/linux/include/asm/rwsem.h:46: parse error before `('
/usr/src/linux/include/asm/rwsem.h:47: parse error before `('
/usr/src/linux/include/asm/rwsem.h:48: parse error before `('
In file included from /usr/src/linux/include/linux/jffs2_fs_sb.h:8,
                 from /usr/src/linux/include/linux/fs.h:692,
                 from /usr/src/linux/include/linux/capability.h:17,
                 from /usr/src/linux/include/linux/binfmts.h:5,
                 from /usr/src/linux/include/linux/sched.h:9,
                 from /usr/src/linux/include/linux/mm.h:4,
                 from /usr/src/linux/include/linux/slab.h:14,
                 from /usr/src/linux/include/linux/proc_fs.h:5,
                 from init/main.c:15:
/usr/src/linux/include/linux/completion.h:30: parse error before `('
/usr/src/linux/include/linux/completion.h:31: parse error before `('
In file included from /usr/src/linux/include/linux/capability.h:17,
                 from /usr/src/linux/include/linux/binfmts.h:5,
                 from /usr/src/linux/include/linux/sched.h:9,
                 from /usr/src/linux/include/linux/mm.h:4,
                 from /usr/src/linux/include/linux/slab.h:14,
                 from /usr/src/linux/include/linux/proc_fs.h:5,
                 from init/main.c:15:
/usr/src/linux/include/linux/fs.h: In function `put_bh':
/usr/src/linux/include/linux/fs.h:1124: warning: implicit declaration of
function `barrier'
/usr/src/linux/include/linux/fs.h: At top level:
/usr/src/linux/include/linux/fs.h:1152: parse error before `('
/usr/src/linux/include/linux/fs.h:1153: parse error before `('
/usr/src/linux/include/linux/fs.h:1154: parse error before `('
/usr/src/linux/include/linux/fs.h:1155: parse error before `('
/usr/src/linux/include/linux/fs.h: In function `mark_buffer_dirty_inode':
/usr/src/linux/include/linux/fs.h:1185: warning: implicit declaration of
function `mark_buffer_dirty'
/usr/src/linux/include/linux/fs.h: At top level:
/usr/src/linux/include/linux/fs.h:1306: parse error before `('
/usr/src/linux/include/linux/fs.h:1307: parse error before `('
/usr/src/linux/include/linux/fs.h:1308: parse error before `('
/usr/src/linux/include/linux/fs.h:1309: parse error before `('
In file included from /usr/src/linux/include/linux/mm.h:4,
                 from /usr/src/linux/include/linux/slab.h:14,
                 from /usr/src/linux/include/linux/proc_fs.h:5,
                 from init/main.c:15:
/usr/src/linux/include/linux/sched.h:155: parse error before `('
In file included from /usr/src/linux/include/linux/mm.h:4,
                 from /usr/src/linux/include/linux/slab.h:14,
                 from /usr/src/linux/include/linux/proc_fs.h:5,
                 from init/main.c:15:
/usr/src/linux/include/linux/sched.h:585: parse error before `('
/usr/src/linux/include/linux/sched.h:586: parse error before `('
/usr/src/linux/include/linux/sched.h:587: parse error before `('
/usr/src/linux/include/linux/sched.h:588: parse error before `('
/usr/src/linux/include/linux/sched.h:590: parse error before `('
/usr/src/linux/include/linux/sched.h:591: parse error before `('
/usr/src/linux/include/linux/sched.h:593: parse error before `('
/usr/src/linux/include/linux/sched.h:755: parse error before `('
/usr/src/linux/include/linux/sched.h: In function `mmdrop':
/usr/src/linux/include/linux/sched.h:759: warning: implicit declaration of
function `__mmdrop'
/usr/src/linux/include/linux/sched.h: At top level:
/usr/src/linux/include/linux/sched.h:792: parse error before `('
/usr/src/linux/include/linux/sched.h:793: parse error before `('
/usr/src/linux/include/linux/sched.h:794: parse error before `('
In file included from /usr/src/linux/include/linux/mm.h:13,
                 from /usr/src/linux/include/linux/slab.h:14,
                 from /usr/src/linux/include/linux/proc_fs.h:5,
                 from init/main.c:15:
/usr/src/linux/include/linux/swap.h:104: parse error before `('
/usr/src/linux/include/linux/swap.h:105: parse error before `('
/usr/src/linux/include/linux/swap.h:106: parse error before `('
/usr/src/linux/include/linux/swap.h:108: parse error before `('
/usr/src/linux/include/linux/swap.h:114: parse error before `('
/usr/src/linux/include/linux/swap.h:161: parse error before `('
In file included from /usr/src/linux/include/linux/slab.h:14,
                 from /usr/src/linux/include/linux/proc_fs.h:5,
                 from init/main.c:15:
/usr/src/linux/include/linux/mm.h:305: parse error before `('
/usr/src/linux/include/linux/mm.h:357: parse error before `('
/usr/src/linux/include/linux/mm.h:358: parse error before `('
/usr/src/linux/include/linux/mm.h: In function `alloc_pages':
/usr/src/linux/include/linux/mm.h:368: warning: implicit declaration of function
`_alloc_pages'
/usr/src/linux/include/linux/mm.h:368: warning: return makes pointer from
integer without a cast
/usr/src/linux/include/linux/mm.h: At top level:
/usr/src/linux/include/linux/mm.h:373: parse error before `('
/usr/src/linux/include/linux/mm.h:374: parse error before `('
/usr/src/linux/include/linux/mm.h:390: parse error before `('
/usr/src/linux/include/linux/mm.h:391: parse error before `('
/usr/src/linux/include/linux/mm.h:413: parse error before `('
/usr/src/linux/include/linux/mm.h:414: parse error before `('
/usr/src/linux/include/linux/mm.h: In function `pmd_alloc':
/usr/src/linux/include/linux/mm.h:436: warning: implicit declaration of function
`__pmd_alloc'
/usr/src/linux/include/linux/mm.h:436: warning: return makes pointer from
integer without a cast
In file included from /usr/src/linux/include/linux/proc_fs.h:5,
                 from init/main.c:15:
/usr/src/linux/include/linux/slab.h: At top level:
/usr/src/linux/include/linux/slab.h:64: parse error before `('
In file included from /usr/src/linux/include/linux/highmem.h:5,
                 from /usr/src/linux/include/linux/pagemap.h:16,
                 from /usr/src/linux/include/linux/locks.h:8,
                 from /usr/src/linux/include/linux/devfs_fs_kernel.h:6,
                 from init/main.c:16:
/usr/src/linux/include/asm/pgalloc.h: In function `get_pgd_slow':
/usr/src/linux/include/asm/pgalloc.h:61: warning: implicit declaration of
function `__get_free_pages'
/usr/src/linux/include/asm/pgalloc.h: In function `free_pgd_slow':
/usr/src/linux/include/asm/pgalloc.h:103: warning: implicit declaration of
function `free_pages'
In file included from /usr/src/linux/include/linux/locks.h:8,
                 from /usr/src/linux/include/linux/devfs_fs_kernel.h:6,
                 from init/main.c:16:
/usr/src/linux/include/linux/pagemap.h: At top level:
/usr/src/linux/include/linux/pagemap.h:32: parse error before `('
/usr/src/linux/include/linux/pagemap.h:82: parse error before `('
/usr/src/linux/include/linux/pagemap.h:83: parse error before `('
In file included from /usr/src/linux/include/linux/devfs_fs_kernel.h:6,
                 from init/main.c:16:
/usr/src/linux/include/linux/locks.h:29: parse error before `('
In file included from init/main.c:32:
/usr/src/linux/include/asm/bugs.h: In function `check_fpu':
/usr/src/linux/include/asm/bugs.h:71: warning: implicit declaration of function
`printk'
/usr/src/linux/include/asm/bugs.h:71: `KERN_EMERG' undeclared (first use in this
function)
/usr/src/linux/include/asm/bugs.h:71: (Each undeclared identifier is reported
only once
/usr/src/linux/include/asm/bugs.h:71: for each function it appears in.)
/usr/src/linux/include/asm/bugs.h:71: parse error before string constant
/usr/src/linux/include/asm/bugs.h:72: parse error before string constant
/usr/src/linux/include/asm/bugs.h:87: `KERN_INFO' undeclared (first use in this
function)
/usr/src/linux/include/asm/bugs.h:87: parse error before string constant
/usr/src/linux/include/asm/bugs.h:92: parse error before string constant
/usr/src/linux/include/asm/bugs.h: In function `check_hlt':
/usr/src/linux/include/asm/bugs.h:115: `KERN_INFO' undeclared (first use in this
function)
/usr/src/linux/include/asm/bugs.h:115: parse error before string constant
/usr/src/linux/include/asm/bugs.h: In function `check_config':
/usr/src/linux/include/asm/bugs.h:170: warning: implicit declaration of function
`panic'
init/main.c: In function `profile_setup':
init/main.c:136: warning: implicit declaration of function `get_option'
init/main.c: In function `name_to_kdev_t':
init/main.c:289: warning: implicit declaration of function `simple_strtoul'
init/main.c: In function `debug_kernel':
init/main.c:397: `console_loglevel' undeclared (first use in this function)
init/main.c: In function `quiet_kernel':
init/main.c:405: `console_loglevel' undeclared (first use in this function)
make: *** [init/main.o] Error 1


Expected Results:  Recompilation of kernel...

Additional info:
Comment 1 Arjan van de Ven 2002-01-30 11:13:46 EST
Looks like you forgot "make mrproper" between changing config files...
kernel.org kernels need that for some changes. (Note: make mrproper erases your
.config file so be sure to make a backup somewhere)
Comment 2 Need Real Name 2002-01-31 07:54:05 EST
I try make mrproper... and the kernel does't recompile:

1) I execute make mrproper
2) I execute make menuconfig and load configuration file (or default configuration)
3) I execute make dep and make bzImage, or make clean, make dep, make bzImage,
but at first gcc action of make bzImage the compilation fails...

[root@kbytelnx linux]# make mrproper
make[1]: Entering directory `/usr/src/linux/arch/i386/boot'
rm -f tools/build
rm -f setup bootsect zImage compressed/vmlinux.out
rm -f bsetup bbootsect bzImage compressed/bvmlinux.out
make[2]: Entering directory `/usr/src/linux/arch/i386/boot/compressed'
rm -f vmlinux bvmlinux _tmp_*
make[2]: Leaving directory `/usr/src/linux/arch/i386/boot/compressed'
make[1]: Leaving directory `/usr/src/linux/arch/i386/boot'
find . \( -name '*.[oas]' -o -name core -o -name '.*.flags' \) -type f -print \
| grep -v lxdialog/ | xargs rm -f
rm -f kernel/ksyms.lst include/linux/compile.h vmlinux System.map .tmp*
drivers/char/consolemap_deftbl.c drivers/video/promcon_tbl.c
drivers/char/conmakehash drivers/char/drm/*-mod.c drivers/pci/devlist.h
drivers/pci/classlist.h drivers/pci/gen-devlist drivers/zorro/devlist.h
drivers/zorro/gen-devlist drivers/sound/bin2hex drivers/sound/hex2hex
drivers/atm/fore200e_mkfirm drivers/atm/{pca,sba}*{.bin,.bin1,.bin2}
drivers/scsi/aic7xxx/aicasm/aicasm_gram.c
drivers/scsi/aic7xxx/aicasm/aicasm_scan.c drivers/scsi/aic7xxx/aicasm/y.tab.h
drivers/scsi/aic7xxx/aicasm/aicasm drivers/scsi/53c700-mem.c
net/khttpd/make_times_h net/khttpd/times.h submenu*
rm -rf modules
make -C Documentation/DocBook clean
make[1]: Entering directory `/usr/src/linux/Documentation/DocBook'
rm -f core *~
rm -f wanbook.sgml z8530book.sgml mcabook.sgml videobook.sgml kernel-api.sgml
parportbook.sgml kernel-hacking.sgml kernel-locking.sgml via-audio.sgml
mousedrivers.sgml sis900.sgml deviceiobook.sgml procfs-guide.sgml tulip-user.sgml
rm -f  wanbook.dvi  z8530book.dvi  mcabook.dvi  videobook.dvi  kernel-api.dvi 
parportbook.dvi  kernel-hacking.dvi  kernel-locking.dvi  via-audio.dvi 
mousedrivers.dvi  sis900.dvi  deviceiobook.dvi  procfs-guide.dvi  tulip-user.dvi
 wanbook.aux  z8530book.aux  mcabook.aux  videobook.aux  kernel-api.aux 
parportbook.aux  kernel-hacking.aux  kernel-locking.aux  via-audio.aux 
mousedrivers.aux  sis900.aux  deviceiobook.aux  procfs-guide.aux  tulip-user.aux
 wanbook.tex  z8530book.tex  mcabook.tex  videobook.tex  kernel-api.tex 
parportbook.tex  kernel-hacking.tex  kernel-locking.tex  via-audio.tex 
mousedrivers.tex  sis900.tex  deviceiobook.tex  procfs-guide.tex  tulip-user.tex
 wanbook.log  z8530book.log  mcabook.log  videobook.log  kernel-api.log 
parportbook.log  kernel-hacking.log  kernel-locking.log  via-audio.log 
mousedrivers.log  sis900.log  deviceiobook.log  procfs-guide.log  tulip-user.log
 wanbook.out  z8530book.out  mcabook.out  videobook.out  kernel-api.out 
parportbook.out  kernel-hacking.out  kernel-locking.out  via-audio.out 
mousedrive tulip-user.out
rm -f  parport-share.png  parport-multi.png  parport-structure.png 
parport-share.eps  parport-multi.eps  parport-structure.eps
rm -f procfs_example.sgml
make[1]: Leaving directory `/usr/src/linux/Documentation/DocBook'
find . \( -size 0 -o -name .depend \) -type f -print | xargs rm -f
rm -f include/linux/autoconf.h include/linux/version.h
drivers/net/hamradio/soundmodem/sm_tbl_{afsk1200,afsk2666,fsk9600}.h
drivers/net/hamradio/soundmodem/sm_tbl_{hapn4800,psk4800}.h
drivers/net/hamradio/soundmodem/sm_tbl_{afsk2400_7,afsk2400_8}.h
drivers/net/hamradio/soundmodem/gentbl drivers/sound/*_boot.h
drivers/sound/.*.boot drivers/sound/msndinit.c drivers/sound/msndperm.c
drivers/sound/pndsperm.c drivers/sound/pndspini.c drivers/atm/fore200e_*_fw.c
drivers/atm/.fore200e_*.fw .version .config* config.in config.old
scripts/tkparse scripts/kconfig.tk scripts/kconfig.tmp scripts/lxdialog/*.o
scripts/lxdialog/lxdialog .menuconfig.log include/asm .hdepend scripts/mkdep
scripts/splsr/src/linux/include/linux/modversions.h kernel.spec
rm -rf include/config /usr/src/linux/include/linux/modules
make -C Documentation/DocBook mrproper
make[1]: Entering directory `/usr/src/linux/Documentation/DocBook'
rm -f core *~
rm -f wanbook.sgml z8530book.sgml mcabook.sgml videobook.sgml kernel-api.sgml
parportbook.sgml kernel-hacking.sgml kernel-locking.sgml via-audio.sgml
mousedrivers.sgml sis900.sgml deviceiobook.sgml procfs-guide.sgml tulip-user.sgml
rm -f  wanbook.dvi  z8530book.dvi  mcabook.dvi  videobook.dvi  kernel-api.dvi 
parportbook.dvi  kernel-hacking.dvi  kernel-locking.dvi  via-audio.dvi 
mousedrivers.dvi  sis900.dvi  deviceiobook.dvi  procfs-guide.dvi  tulip-user.dvi
 wanbook.aux  z8530book.aux  mcabook.aux  videobook.aux  kernel-api.aux 
parportbook.aux  kernel-hacking.aux  kernel-locking.aux  via-audio.aux 
mousedrivers.aux  sis900.aux  deviceiobook.aux  procfs-guide.aux  tulip-user.aux
 wanbook.tex  z8530book.tex  mcabook.tex  videobook.tex  kernel-api.tex 
parportbook.tex  kernel-hacking.tex  kernel-locking.tex  via-audio.tex 
mousedrivers.tex  sis900.tex  deviceiobook.tex  procfs-guide.tex  tulip-user.tex
 wanbook.log  z8530book.log  mcabook.log  videobook.log  kernel-api.log 
parportbook.log  kernel-hacking.log  kernel-locking.log  via-audio.log 
mousedrivers.log  sis900.log  deviceiobook.log  procfs-guide.log  tulip-user.log
 wanbook.outk.out  kernel-api.out  parportbook.out  kernel-hacking.out 
kernel-locking.out  via-audio.out  mousedrivers.out  sis900.out 
deviceiobook.out  procfs-guide.out  tulip-user.out
rm -f  parport-share.png  parport-multi.png  parport-structure.png 
parport-share.eps  parport-multi.eps  parport-structure.eps
rm -f procfs_example.sgml
rm -f  wanbook.ps  z8530book.ps  mcabook.ps  videobook.ps  kernel-api.ps 
parportbook.ps  kernel-hacking.ps  kernel-locking.ps  via-audio.ps 
mousedrivers.ps  sis900.ps  deviceiobook.ps  procfs-guide.ps  tulip-user.ps 
wanbook.pdf  z8530book.pdf  mcabook.pdf  videobook.pdf  kernel-api.pdf 
parportbook.pdf  kernel-hacking.pdf  kernel-locking.pdf  via-audio.pdf 
mousedrivers.pdf  sis900.pdf  deviceiobook.pdf  procfs-guide.pdf  tulip-user.pdf
rm -f -r  wanbook  z8530book  mcabook  videobook  kernel-api  parportbook 
kernel-hacking  kernel-locking  via-audio  mousedrivers  sis900  deviceiobook 
procfs-guide  tulip-user
rm -f .depend
rm -f /usr/src/linux/scripts/mkdep-docbook
rm -rf DBTOHTML_OUTPUT*
make[1]: Leaving directory `/usr/src/linux/Documentation/DocBook'
  z8530book.out  mcabook.out  videobooit-include scripts/docproc /urs.out 
sis900.out  deviceiobook.out  procfs-guide.out 

Some problems here????
Comment 3 Arjan van de Ven 2002-02-01 11:08:50 EST
Hmm this works for me. Try another kernel maybe..

Note You need to log in before you can comment on or make changes to this bug.