Bug 590756 - Update to nss-softokn-3.12.4-17.fc12 causes severe authentication issues
Summary: Update to nss-softokn-3.12.4-17.fc12 causes severe authentication issues
Keywords:
Status: CLOSED DUPLICATE of bug 590247
Alias: None
Product: Fedora
Classification: Fedora
Component: nss-softokn
Version: 12
Hardware: x86_64
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Elio Maldonado Batiz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-10 15:53 UTC by Dan Book
Modified: 2010-05-10 17:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-10 15:56:56 UTC
Type: ---


Attachments (Terms of Use)

Description Dan Book 2010-05-10 15:53:10 UTC
Description of problem:
After updating the packages nss-softokn and nss-softokn-freebl on my server to 3.12.4-17.fc12 I discovered I was unable to log in via SSH, FTP or the console provided by the host. I was able to reset the root password through the host and subsequently log in, but running passwd to reset any other passwords resulted in a segmentation fault. According to the logs, pam reported authentication failures whenever any account tried to log in using the correct password. I also saw these messages in the logs:

May 10 11:11:31 bookdslc kernel: [   89.168997] prelink[2298]: segfault at 4f3625 ip 00000000004002f8 sp 00007fff3a2546f8 error 7 in prelink[400000+123000]
May 10 11:11:44 bookdslc kernel: [  101.261034] passwd[2299]: segfault at 0 ip 000000380927f4d0 sp 00007fff48283cc8 error 4 in libc-2.11.1.so[3809200000+16f000]
May 10 11:12:05 bookdslc kernel: [  122.614483] passwd[2302]: segfault at 0 ip 000000380927f4d0 sp 00007fff6699b148 error 4 in libc-2.11.1.so[3809200000+16f000]

As the only recent update relevant to authentication was nss-softokn and nss-softokn-freebl, I checked the changelog and saw something related to prelink, so I downgraded the packages with yum. I am now running version 3.12.4-10.fc12 of both packages and authentication is working properly, with accounts that never had their password changed during the process.

Version-Release number of selected component (if applicable):
3.12.4-17.fc12

How reproducible:
Unknown

Steps to Reproduce:
1. Attempt to log in or use passwd
  
Actual results:
Authentication failure or segmentation fault

Expected results:
Successful login or password change

Additional info:

Comment 1 Dan Book 2010-05-10 15:56:56 UTC
Prior to reporting this bug I could not search specifically by nss-softokn so I did not see the bug already reported.

*** This bug has been marked as a duplicate of bug 590247 ***

Comment 2 Elio Maldonado Batiz 2010-05-10 16:28:07 UTC
See bugs 590190, 504949, and 590508 for the gory details. For the time being downgrading nss-softokn and nss-softokn-frebl to the previous version, as you did, is right thing to do. A fix is in the works.

Comment 3 Elio Maldonado Batiz 2010-05-10 17:09:55 UTC
Prelink 0.4.3 has was submitted to F-12 updates-testing
http://koji.fedoraproject.org/koji/buildinfo?buildID=166845
Please, try it out. It will help solve this problem.


Note You need to log in before you can comment on or make changes to this bug.