Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 590760 - compiling a xen config produces lots of pud_present warnings
compiling a xen config produces lots of pud_present warnings
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Don Zickus
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-10 11:58 EDT by Don Zickus
Modified: 2011-01-13 16:31 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 16:31:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2011:0017 normal SHIPPED_LIVE Important: Red Hat Enterprise Linux 5.6 kernel security and bug fix update 2011-01-13 05:37:42 EST

  None (edit)
Description Don Zickus 2010-05-10 11:58:26 EDT
Description of problem:

Using a kernel xen config to compile produces a huge amount of compiler
warnings, such that it makes it hard to see if any changes my patch created
causes any new warnings.

The warning is

include/asm/mach-xen/asm/pgtable.h: In function ‘pud_present’:
include/asm/mach-xen/asm/pgtable.h:102: warning: ‘pud_val’ is static but
used in inline function ‘pud_present’ which is not static

A simple fix corrects the problem and life is happy again.
Comment 1 RHEL Product and Program Management 2010-08-06 01:09:16 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Jarod Wilson 2010-08-12 22:24:02 EDT
in kernel-2.6.18-212.el5
You can download this test kernel from http://people.redhat.com/jwilson/el5

Detailed testing feedback is always welcomed.
Comment 8 Petr Beňas 2010-12-14 09:30:30 EST
Verified in 2.6.18-212.el5. 
Compiling kernel with xen config, no warning looking like the one from bug description is printed. Although compiling -211.el5 kernel does not reproduce.
Also verified the patch went to 212.el5.
Comment 10 errata-xmlrpc 2011-01-13 16:31:04 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2011-0017.html

Note You need to log in before you can comment on or make changes to this bug.