Bug 590774 - plymouth does not unlock tty1 properly when exiting
plymouth does not unlock tty1 properly when exiting
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: plymouth (Show other bugs)
6.0
All Linux
high Severity high
: beta
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-10 12:40 EDT by Steve Grubb
Modified: 2010-11-10 16:20 EST (History)
4 users (show)

See Also:
Fixed In Version: plymouth-0.8.3-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:20:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2010-05-10 12:40:01 EDT
Description of problem:
When RHEL6 beta is installed using the minimal install option, the keyboard arrows/tab do not display correctly. For example, if I type "chk" and then hit tab, the cursor jumps to the right about 8 spaces and I do not see any tab completion.

Hitting up arrow should show me the history, but all I see is ^[[A  the down arrow gives me ^[[B.


Version-Release number of selected component (if applicable):
bash-4.1.2-2.el6
Comment 2 RHEL Product and Program Management 2010-05-10 14:00:54 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Ray Strode [halfline] 2010-05-10 14:23:33 EDT
This is fallout from a problem in the patch in bug 582265
Comment 4 Ray Strode [halfline] 2010-05-10 14:26:44 EDT
Note this bug also causes usernames to show up hidden and passwords to show up visible on tty1 when logging in.
Comment 5 Ray Strode [halfline] 2010-05-10 14:36:30 EDT
This was actually fixed in plymouth-0.8.3-1.el6.  After installing it, make sure to rebuild your initrd by installing a kernel or running /usr/libexec/plymouth/plymouth-update-initrd
Comment 6 Steve Grubb 2010-05-10 16:11:58 EDT
Installing 0.8.3 is confirmed as fixing both login password being displayed as well as the tab completion.
Comment 8 Ray Strode [halfline] 2010-05-14 10:01:52 EDT
Something is funny here.  I'm going to need to do another build.
Comment 9 Ray Strode [halfline] 2010-05-14 10:31:19 EDT
Should be fixed in plymouth-0.8.3-2.el6

I think what happened was:

1) At some point I added the patch to the source tree and did a local build and verified it.
2) I then got distracted by some other issue and forgot about it
3) Then this bug came along I went to my cvs checkout and saw the patch was already applied, wrote comment 5 and moved to MODIFIED, not realizing it wasn't built in brew yet.

What I don't understand is how plymouth-0.8.3-1.el6 fixes the problem for those hit by it.

Anyway, we definitely need the patch, so I've built -2 now.

Sorry for the confusion and mistakes.
Comment 10 Ray Strode [halfline] 2010-05-14 10:47:44 EDT
*** Bug 591386 has been marked as a duplicate of this bug. ***
Comment 12 Radek Lat 2010-08-24 07:59:42 EDT
Tested and Verified after clean minimal install on plymouth-0.8.3-17.el6.x86_64, moving to VERIFIED.
Comment 13 releng-rhel@redhat.com 2010-11-10 16:20:31 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.