Bug 590800 - RFE for ability to Manually add filesystems not discovered
RFE for ability to Manually add filesystems not discovered
Status: CLOSED DUPLICATE of bug 553034
Product: RHQ Project
Classification: Other
Component: Configuration (Show other bugs)
1.3.1
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: dsteigne
Corey Welton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-10 13:58 EDT by dsteigne
Modified: 2010-09-24 12:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-24 12:54:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dsteigne 2010-05-10 13:58:43 EDT
Description of problem:

Currently, JON will only inventory local and network file systems.  For local file systems, the Solaris native library only identifies file system types of ufs as being local.  From the output for /var, /opt, etc, the file system type is lsof which is a loopback file system type on Solaris.  These file systems will be ignored by JON as the underlying type is not known or guaranteed.

Customer would like the ability to manually add filesystems to JON.
Comment 1 Corey Welton 2010-09-24 08:25:38 EDT
 ips - does sigar support this?
Comment 2 Ian Springer 2010-09-24 10:09:39 EDT
Debbie-

Please run the below commands on a Solaris box and paste the output into this BZ:

cd JON_AGENT_HOME/lib
java -jar sigar.jar df

This will help me add support for autodiscovering lsof filesystems.

I'd do it myself, but I don't have a Solaris box handy.
Comment 3 Steve Murphy 2010-09-24 10:17:42 EDT
Here's an example for you...  This is using the agent provided with JON 2.4.0GA

/opt/jboss/rhq-agent/lib$ java -jar sigar-1.6.5.132.jar df
Filesystem      Size Used Avail Use% Mounted on      Type
/               6.0G 4.3G  1.6G  73% /               vxfs/local
/dev            6.0G 4.3G  1.6G  73% /dev            lofs/none
/opt             25G 2.0G   22G   9% /opt            lofs/none
/var            4.0G 1.5G  2.3G  40% /var            lofs/none
proc              0    0     0     - /proc           proc/none
ctfs              0    0     0     - /system/contract ctfs/none
mnttab            0    0     0     - /etc/mnttab     mntfs/none
objfs             0    0     0     - /system/object  objfs/none
swap            114G 320K  114G    - /etc/svc/volatile tmpfs/none
/platform/sun4u-us3/lib/libc_psr/libc_psr_hwcap2.so.1 6.0G 4.3G  1.6G  73% /platform/sun4u-us3/lib/libc_psr.so.1 lofs/none
/platform/sun4u-us3/lib/sparcv9/libc_psr/libc_psr_hwcap2.so.1 6.0G 4.3G  1.6G  73% /platform/sun4u-us3/lib/sparcv9/libc_psr.so.1 lofs/none
fd                0    0     0     - /dev/fd         fd/none
swap            114G 210M  114G   1% /tmp            tmpfs/none
swap            114G  32K  114G    - /var/run        tmpfs/none
ppust1:/vol/media/solaris_software 500G 307G  193G  62% /mnt            nfs/remote
Comment 4 Ian Springer 2010-09-24 12:54:39 EDT
It turns out support for autodiscovering lofs and tmpfs filesystems has already been added in RHQ HEAD and so will debut in RHQ 4.0.

See https://bugzilla.redhat.com/show_bug.cgi?id=553034.

*** This bug has been marked as a duplicate of bug 553034 ***

Note You need to log in before you can comment on or make changes to this bug.