Bug 590889 - [abrt] crash in free42-1.4.66-1.fc12: raise: Process /usr/bin/free42dec was killed by signal 6 (SIGABRT)
[abrt] crash in free42-1.4.66-1.fc12: raise: Process /usr/bin/free42dec was k...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: free42 (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Eric Smith
Fedora Extras Quality Assurance
abrt_hash:c14f0b6f7a196880be9d7010a0d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-10 17:25 EDT by Nivag
Modified: 2010-05-13 02:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-13 02:58:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (20.75 KB, text/plain)
2010-05-10 17:25 EDT, Nivag
no flags Details

  None (edit)
Description Nivag 2010-05-10 17:25:14 EDT
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: free42dec
component: free42
crash_function: raise
executable: /usr/bin/free42dec
global_uuid: c14f0b6f7a196880be9d7010a0d32db3123bf2ae
kernel: 2.6.32.11-99.fc12.x86_64
package: free42-1.4.66-1.fc12
rating: 4
reason: Process /usr/bin/free42dec was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

comment
-----
I had run the calculator from the command line, and from its menu item in the accessories menu without poroblems!

However, when I created a menu item in my own frequently used menu, it crashed the first time I clicked on the menu item!

How to reproduce
-----
1.created menu item
2.clicked on menu item
3.crash
Comment 1 Nivag 2010-05-10 17:25:17 EDT
Created attachment 412975 [details]
File: backtrace
Comment 2 Eric Smith 2010-05-10 21:14:58 EDT
The backtrace shows that the error occurs in XmuClientWindow, but I can't reproduce it.  I've added a free42 launcher to the Gnome panel, and that works fine.  I'm not sure how to create "my own frequently used menu", so I haven't tried that.  I seem to recall that earlier versions of the Gnome panel had an easy way to add a new empty menu to the panel or to an existing menu, but I can't find it now.
Comment 3 Nivag 2010-05-10 21:50:26 EDT
# yum info alacarte
Loaded plugins: auto-update-debuginfo, presto, refresh-packagekit
Found 191 installed debuginfo package(s)
Installed Packages
Name       : alacarte
Arch       : noarch
Version    : 0.12.4
Release    : 1.fc12
Size       : 359 k
Repo       : installed
From repo  : fedora
Summary    : Menu editor for the GNOME desktop
URL        : http://www.gnome.org
License    : LGPLv2+
Description: Alacarte is a graphical menu editor that lets you edit, add, and delete
           : menu entries. It follows the freedesktop.org menu specification and
           : should work with any desktop environment that uses this specification.

# 

When I clicked on the item the second time, it worked with no apparent problems!
Comment 4 Eric Smith 2010-05-13 02:58:30 EDT
alacarte is so buggy for me that I am unable to create the menu item; in fact, it is so buggy that I can't even figure out how to write a reasonable bug report for it. "It is not even wrong", as Wolfgang Pauli famously said.

Anyhow, since I can't reproduce it and apparently it now works for you, I'm closing the bug.  If you can get it to happen again, please reopen it.

Note You need to log in before you can comment on or make changes to this bug.