Bug 590907 - MacBook Pro 13" (5,5) front speaker muted by default
MacBook Pro 13" (5,5) front speaker muted by default
Status: CLOSED DUPLICATE of bug 580703
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
: 590906 (view as bug list)
Depends On:
Blocks: AlsaVolume
  Show dependency treegraph
 
Reported: 2010-05-10 19:03 EDT by François Kooman
Modified: 2011-04-27 18:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-17 17:23:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info for MacBook Pro 13" 5,5 (20.64 KB, text/plain)
2010-05-10 19:03 EDT, François Kooman
no flags Details
Before (1.80 KB, text/plain)
2010-05-10 19:04 EDT, François Kooman
no flags Details
After (1.81 KB, text/plain)
2010-05-10 19:04 EDT, François Kooman
no flags Details

  None (edit)
Description François Kooman 2010-05-10 19:03:18 EDT
Created attachment 412994 [details]
alsa-info for MacBook Pro 13" 5,5

Description of problem:

On MacBook Pro 13" (5,5) summer 2009 edition the front speaker is muted by default. Modifying this (unmute + setting volume to 0dB fixes it). This report is for the built in speakers.

Version-Release number of selected component (if applicable):

alsa-lib-1.0.23-1.fc13.x86_64

How reproducible:

always
  
Actual results:

No sound without modifying mixer (alsamixer -c 0)

Expected results:

Sound by default

Additional info:

See attachments.
Comment 1 François Kooman 2010-05-10 19:04:14 EDT
Created attachment 412995 [details]
Before
Comment 2 François Kooman 2010-05-10 19:04:37 EDT
Created attachment 412996 [details]
After
Comment 3 François Kooman 2010-05-11 09:01:47 EDT
*** Bug 590906 has been marked as a duplicate of this bug. ***
Comment 4 luca tosatto 2010-06-23 06:54:07 EDT
If I can help a quick fix it to add the following lines to 

/etc/rc.local

amixer -c 0 set 'Surround Speaker' 115 unmute
amixer -c 0 set 'Front Speaker' 115 unmute
amixer -c 0 set 'Surround Speaker Playback Volum' 115 unmute


... This is what i did on my Macbook Pro 5.4  :)

Luca
Comment 5 Bug Zapper 2010-07-30 07:36:03 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Marius Andreiana 2010-11-17 17:23:00 EST
The workaround from Luca didn't work for me

*** This bug has been marked as a duplicate of bug 580703 ***
Comment 7 Christian Kujau 2011-04-27 18:48:58 EDT
> amixer -c 0 set 'Surround Speaker' 115 unmute

...did the trick on my MacBookPro5,5.

> amixer -c 0 set 'Front Speaker' 115 unmute

The "Front Speaker" command unmutes some very strange speaker, it sounds kinda "metallic", with no bass, so I turned it off again. Together with the "Surround Speaker" it sounds a bit better, but overall sound experience is still awful compared to what I have under MacOSX. But at least it's "working" now!

> amixer -c 0 set 'Surround Speaker Playback Volum' 115 unmute

The "Surround Speaker Playback Volum" command did nothing here.


Thanks, Luca!

$ lspci | grep Audio
00:08.0 Audio device: nVidia Corporation MCP79 High Definition Audio (rev b1)

Note You need to log in before you can comment on or make changes to this bug.