Bug 590923 - /sbin/mkdumprd spins forever doing "readlink"
Summary: /sbin/mkdumprd spins forever doing "readlink"
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kexec-tools   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Neil Horman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-11 00:12 UTC by Roland McGrath
Modified: 2010-05-13 19:26 UTC (History)
1 user (show)

Fixed In Version: kexec-tools-2.0.0-35.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-13 19:26:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
-x log (11.58 KB, text/plain)
2010-05-11 16:24 UTC, Roland McGrath
no flags Details
patch to fix how we sift through sysfs (725 bytes, patch)
2010-05-12 15:40 UTC, Neil Horman
no flags Details | Diff
updated patch (865 bytes, patch)
2010-05-12 18:46 UTC, Neil Horman
no flags Details | Diff

Description Roland McGrath 2010-05-11 00:12:28 UTC
Description of problem:

First noticed during boot with kexec-tools installed,
also happens with manual "service kexec-tools start".
It spins forever chewing CPU.
I found that running /sbin/mkdumprd is where it happens and doing this by hand hits it too.

I've attached the log of running "bash -x /sbin/mkdumprd ..." where it eventually runs "readlink /sys/class/block/sda5" repeatedly forever.

Version-Release number of selected component (if applicable):
kexec-tools-2.0.0-34.fc13.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Neil Horman 2010-05-11 11:10:33 UTC
could you attach that file please?  thanks !

Comment 2 Roland McGrath 2010-05-11 16:24:25 UTC
Created attachment 413187 [details]
-x log

Oops, thought I'd attached it in the initial report.

Comment 3 Neil Horman 2010-05-12 15:40:26 UTC
Created attachment 413462 [details]
patch to fix how we sift through sysfs

looks like I forgot to port a RHEL patch over to Fedora.  Let me know if this fixes your problem.  Thanks!

Comment 4 Roland McGrath 2010-05-12 18:11:39 UTC
With that, the infinite loop is instead:

++ readlink ./device

Comment 5 Neil Horman 2010-05-12 18:46:55 UTC
Created attachment 413521 [details]
updated patch

sorry, missed a hunk from the backport.

Comment 6 Roland McGrath 2010-05-12 19:26:33 UTC
That fixes mkdumprd I guess.  It completed.  But "service kdump start" is not happy.  It just says "FAILED" with no details.  syslog gets:

May 12 12:25:46 magilla kdump: No crashkernel parameter specified for running kernel
May 12 12:25:46 magilla kdump: failed to start up

Comment 7 Neil Horman 2010-05-12 19:28:32 UTC
It told you exactly what the problem was:

"No crashkernel parameter specified for running
kernel"

you need to specify a crashkernel command line parameter on the kernel command line.  For x86 system crashkernel=128M is usually sufficient.

I'll commit this change shortly.  Thanks!

Comment 8 Roland McGrath 2010-05-12 19:37:47 UTC
I'm using what you get out of the box for booting F-13 with kexec-tools installed.  I don't want to fiddle kernel parameters by hand.  Either it should just work, or it should not be chkconfig on by default.

Comment 9 Fedora Update System 2010-05-12 20:10:54 UTC
kexec-tools-2.0.0-35.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/kexec-tools-2.0.0-35.fc13

Comment 10 Fedora Update System 2010-05-13 19:26:27 UTC
kexec-tools-2.0.0-35.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.