Bug 590961 - perldoc nroff: command not found
Summary: perldoc nroff: command not found
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: perl   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-11 05:09 UTC by Ralf Corsepius
Modified: 2010-07-09 06:08 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-09 06:08:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ralf Corsepius 2010-05-11 05:09:23 UTC
Description of problem:

When building some perl-modules with perl-5.12-0-122, I am observing this:
...
+ /usr/bin/gzip -dc /builddir/build/SOURCES/Catalyst-Runtime-5.80021.tar.gz
+ /bin/tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd Catalyst-Runtime-5.80021
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ perldoc perlgpl
sh: nroff: command not found
+ perldoc perlartistic
sh: nroff: command not found
...

Version-Release number of selected component (if applicable):
perl-5.12.0-122

How reproducible:
Always


Steps to Reproduce:
1. try rebuilding perl-Catalyst-Runtime-5.80021


  
Actual results:
c.f. above.

Expected results:
No warning.

Additional info:
Smells like either a build/configuration error in perl 
or a missing dependency of the package containing 
/usr/bin/perldoc (i.e. ATM, the "perl" package) to me.

Comment 1 Marcela Mašláňová 2010-05-11 11:56:36 UTC
I guess you are missing groff as BuildRequirement. It was probably removed from minimal install, because not many packages use it during build.

Comment 2 Ralf Corsepius 2010-05-11 12:21:32 UTC
(In reply to comment #1)
> I guess you are missing groff as BuildRequirement. It was probably removed from
> minimal install, because not many packages use it during build.    

I am using mock with a slightly modifed "fc13" configuration (Urls tweaked to point to "14" instead of "13" and a repo containing a local perl-5.12.0 rebuild added.

The bug is reproducable in koji:
http://koji.fedoraproject.org/koji/getfile?taskID=2179572&name=build.log

Comment 3 Ralf Corsepius 2010-05-11 12:30:15 UTC
Sorry forgot the task id (a scatch built of a fedora-13 package against
perl-f14-perltest)
http://koji.fedoraproject.org/koji/taskinfo?taskID=2179571

Comment 4 Marcela Mašláňová 2010-07-08 13:37:55 UTC
Perldoc calls: pod2man | nroff -man | $PAGER so if you don't install groff, which provides nroff, it can't work. 

Mock didn't contain groff so it should have this problem even before. The only change between F-13 and F-14 was using man-db instead of man. Also I removed 'man' as BR from perl. But these changes shouldn't have any effect on this issue.

Comment 5 Ralf Corsepius 2010-07-08 14:07:07 UTC
(In reply to comment #4)
> Mock didn't contain groff so it should have this problem even before. The only
> change between F-13 and F-14 was using man-db instead of man. Also I removed
> 'man' as BR from perl. But these changes shouldn't have any effect on this
> issue.    
Well, I haven't checked if this issue is new, I only reported an issue which I was observing when rebuilding rawhide's perl ;)

Comment 6 Marcela Mašláňová 2010-07-09 06:08:49 UTC
It's old issue. http://kojipkgs.fedoraproject.org/packages/perl-Catalyst-Runtime/5.80013/2.fc12/data/logs/noarch/build.log

Simply add BR: groff into every package, which miss it. I added it into perl-Catalyst-Runtime.


Note You need to log in before you can comment on or make changes to this bug.