Bug 590973 - Errors on upgrade from f11/f12 to f13 Package compat-db-4.7.25-2.fc13.x86_64 requires compat-db45 = ('0', '4.5.20', '2.fc13')
Errors on upgrade from f11/f12 to f13 Package compat-db-4.7.25-2.fc13.x86_64 ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: compat-db (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 02:16 EDT by Grant Williamson
Modified: 2013-07-02 19:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: compat-db-4.7.25-17.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-04 01:21:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Grant Williamson 2010-05-11 02:16:08 EDT
Description of problem:
Upgrade from f11/f12 to fedora 13, does not upgrade compat-db correctly.


Preupgrade machine, run a package-cleanup

Package compat-db-4.7.25-2.fc13.x86_64 requires compat-db45 = ('0', '4.5.20', '2.fc13')
Package compat-db-4.7.25-2.fc13.x86_64 requires compat-db46 = ('0', '4.6.21', '2.fc13')


rpm -qa | grep compat-db
compat-db47-4.7.25-2.fc13.x86_64
compat-db-4.7.25-2.fc13.x86_64
compat-db45-4.5.20-5.fc10.x86_64
compat-db46-4.6.21-5.fc10.x86_64
Comment 1 Rahul Sundaram 2010-06-16 11:29:15 EDT
Can you please fix this up?  It causes breakages for upgrades.
Comment 2 Fedora Update System 2010-06-17 03:58:50 EDT
compat-db-4.7.25-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/compat-db-4.7.25-3.fc13
Comment 3 Fedora Update System 2010-06-17 04:04:13 EDT
compat-db-4.6.21-11.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/compat-db-4.6.21-11.fc12
Comment 4 Fedora Update System 2010-06-21 08:58:12 EDT
compat-db-4.6.21-11.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update compat-db'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/compat-db-4.6.21-11.fc12
Comment 5 Fedora Update System 2010-06-21 09:14:04 EDT
compat-db-4.7.25-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update compat-db'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/compat-db-4.7.25-3.fc13
Comment 6 Fedora Update System 2010-06-28 13:08:25 EDT
compat-db-4.6.21-11.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2010-06-28 13:14:26 EDT
compat-db-4.7.25-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Alex Lancaster 2010-07-04 18:21:46 EDT
There is still a broken upgrade path:

# sudo yum update
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package compat-db.x86_64 0:4.7.25-3.fc13 set to be updated
--> Processing Dependency: compat-db46(x86-64) = 4.6.21-3.fc13 for package: compat-db-4.7.25-3.fc13.x86_64
--> Processing Dependency: compat-db45(x86-64) = 4.5.20-3.fc13 for package: compat-db-4.7.25-3.fc13.x86_64
--> Finished Dependency Resolution
Error: Package: compat-db-4.7.25-3.fc13.x86_64 (updates)
           Requires: compat-db46(x86-64) = 4.6.21-3.fc13
           Installed: compat-db46-4.6.21-5.fc10.x86_64 (@fedora/11)
           Available: compat-db46-4.6.21-2.fc13.x86_64 (fedora)
           Available: compat-db46-4.6.21-3.fc13.x86_64 (updates)
Error: Package: compat-db-4.7.25-3.fc13.x86_64 (updates)
           Requires: compat-db45(x86-64) = 4.5.20-3.fc13
           Installed: compat-db45-4.5.20-5.fc10.x86_64 (@fedora/11)
           Available: compat-db45-4.5.20-2.fc13.x86_64 (fedora)
           Available: compat-db45-4.5.20-3.fc13.x86_64 (updates)
 You could try using --skip-broken to work around the problem
compat-db-4.7.25-2.fc13.x86_64 has missing requires of compat-db45 = ('0', '4.5.20', '2.fc13')
compat-db-4.7.25-2.fc13.x86_64 has missing requires of compat-db46 = ('0', '4.6.21', '2.fc13')
gnome-compiz-manager-0.10.4-8.fc11.x86_64 has missing requires of libgnome-desktop-2.so.11()(64bit)
pdfcube-0.0.3-5.fc12.x86_64 has missing requires of libboost_program_options-mt.so.5()(64bit)
rpmfusion-free-release-14-0.2.noarch has missing requires of system-release >= ('0', '14', None)
rpmfusion-nonfree-release-14-0.2.noarch has missing requires of system-release >= ('0', '14', None)
telepathy-feed-0.13-7.fc12.x86_64 has missing requires of libtelepathy.so.2()(64bit)
Comment 9 Răzvan Sandu 2010-07-08 15:28:07 EDT
I think that's the same bug: whem performing online upgrades in F13 (x86_64), I get:

 Transaction Check Error:
  file /usr/include/db4.7.25/db.h from install of compat-db47-4.7.25-3.fc13.x86_64 conflicts with file from package compat-db47-4.7.25-2.fc13.i686
Comment 10 Alex Lancaster 2010-07-10 01:41:34 EDT
This is still an issue, could the maintainer please respond with a status update?  

This dep breakage is blocking updates for almost a week.
Comment 11 Fedora Update System 2010-07-12 06:17:14 EDT
compat-db-4.7.25-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/compat-db-4.7.25-4.fc13
Comment 12 Jindrich Novy 2010-07-12 06:20:52 EDT
Could you please test this new update? I moved the conflicting headers to separate noarch subpackage so that these conflicts are no more possible ...and I've done some dependencies fixes. I will do the same thing for F12 if it turn out it fixes the update problem for you.

If the update works for you, please give it a positive karma so that we can see this resolved in stable as well ASAP.
Comment 13 Fedora Update System 2010-07-13 03:49:30 EDT
compat-db-4.7.25-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update compat-db'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/compat-db-4.7.25-4.fc13
Comment 14 Alex Lancaster 2010-07-13 05:06:27 EDT
(In reply to comment #12)
> Could you please test this new update? I moved the conflicting headers to
> separate noarch subpackage so that these conflicts are no more possible ...and
> I've done some dependencies fixes. I will do the same thing for F12 if it turn
> out it fixes the update problem for you.
> 
> If the update works for you, please give it a positive karma so that we can see
> this resolved in stable as well ASAP.    

Nope, still doesn't work:

sudo yum  install --enablerepo=updates-testing compat-db
Loaded plugins: allowdowngrade, auto-update-debuginfo, changelog, downloadonly,
              : fastestmirror, presto, priorities, protectbase, refresh-
              : packagekit, tmprepo, tsflags, versionlock
Found 79 installed debuginfo package(s)
Enabling fedora-debuginfo: Fedora 13 - x86_64 - Debug
Enabling rpmfusion-nonfree-debuginfo: RPM Fusion for Fedora 13 - Nonfree - Debug
Enabling updates-testing-debuginfo: Fedora 13 - x86_64 - Test Updates Debug
Enabling rpmfusion-free-updates-debuginfo: RPM Fusion for Fedora 13 - Free - Updates Debug
Enabling rpmfusion-free-debuginfo: RPM Fusion for Fedora 13 - Free - Debug
Enabling updates-debuginfo: Fedora 13 - x86_64 - Updates - Debug
Enabling rpmfusion-nonfree-updates-debuginfo: RPM Fusion for Fedora 13 - Nonfree - Updates Debug
Loading mirror speeds from cached hostfile
 * fedora: mirror.liberty.edu
 * fedora-debuginfo: mirror.cogentco.com
 * rpmfusion-free: mirror.liberty.edu
 * rpmfusion-free-debuginfo: mirror.liberty.edu
 * rpmfusion-free-updates: mirror.liberty.edu
 * rpmfusion-free-updates-debuginfo: mirror.liberty.edu
 * rpmfusion-nonfree: mirror.liberty.edu
 * rpmfusion-nonfree-debuginfo: mirror.liberty.edu
 * rpmfusion-nonfree-updates: mirror.liberty.edu
 * rpmfusion-nonfree-updates-debuginfo: mirror.liberty.edu
 * updates: mirror.liberty.edu
 * updates-debuginfo: mirror.cogentco.com
 * updates-testing-debuginfo: fedora.mirrors.tds.net
0 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package compat-db.x86_64 0:4.7.25-4.fc13 set to be updated
--> Processing Dependency: compat-db45(x86-64) = 4.5.20-4.fc13 for package: compat-db-4.7.25-4.fc13.x86_64
--> Processing Dependency: compat-db46(x86-64) = 4.6.21-4.fc13 for package: compat-db-4.7.25-4.fc13.x86_64
--> Processing Dependency: compat-db47(x86-64) = 4.7.25-4.fc13 for package: compat-db-4.7.25-4.fc13.x86_64
--> Running transaction check
---> Package compat-db.x86_64 0:4.7.25-4.fc13 set to be updated
--> Processing Dependency: compat-db45(x86-64) = 4.5.20-4.fc13 for package: compat-db-4.7.25-4.fc13.x86_64
--> Processing Dependency: compat-db46(x86-64) = 4.6.21-4.fc13 for package: compat-db-4.7.25-4.fc13.x86_64
---> Package compat-db47.x86_64 0:4.7.25-4.fc13 set to be updated
--> Processing Dependency: compat-db-headers = 4.7.25-4.fc13 for package: compat-db47-4.7.25-4.fc13.x86_64
--> Running transaction check
---> Package compat-db.x86_64 0:4.7.25-4.fc13 set to be updated
--> Processing Dependency: compat-db45(x86-64) = 4.5.20-4.fc13 for package: compat-db-4.7.25-4.fc13.x86_64
--> Processing Dependency: compat-db46(x86-64) = 4.6.21-4.fc13 for package: compat-db-4.7.25-4.fc13.x86_64
---> Package compat-db-headers.noarch 0:4.7.25-4.fc13 set to be updated
--> Finished Dependency Resolution
Error: Package: compat-db-4.7.25-4.fc13.x86_64 (updates-testing)
           Requires: compat-db45(x86-64) = 4.5.20-4.fc13
           Installed: compat-db45-4.5.20-5.fc10.x86_64 (@fedora/11)
           Available: compat-db45-4.5.20-2.fc13.x86_64 (fedora)
           Available: compat-db45-4.5.20-3.fc13.x86_64 (updates)
           Available: compat-db45-4.5.20-4.fc13.x86_64 (updates-testing)
Error: Package: compat-db-4.7.25-4.fc13.x86_64 (updates-testing)
           Requires: compat-db46(x86-64) = 4.6.21-4.fc13
           Installed: compat-db46-4.6.21-5.fc10.x86_64 (@fedora/11)
           Available: compat-db46-4.6.21-2.fc13.x86_64 (fedora)
           Available: compat-db46-4.6.21-3.fc13.x86_64 (updates)
           Available: compat-db46-4.6.21-4.fc13.x86_64 (updates-testing)
 You could try using --skip-broken to work around the problem
compat-db-4.7.25-2.fc13.x86_64 has missing requires of compat-db45 = ('0', '4.5.20', '2.fc13')
compat-db-4.7.25-2.fc13.x86_64 has missing requires of compat-db46 = ('0', '4.6.21', '2.fc13')
gnome-compiz-manager-0.10.4-8.fc11.x86_64 has missing requires of libgnome-desktop-2.so.11()(64bit)
pdfcube-0.0.3-5.fc12.x86_64 has missing requires of libboost_program_options-mt.so.5()(64bit)
rpmfusion-free-release-14-0.2.noarch has missing requires of system-release >= ('0', '14', None)
rpmfusion-nonfree-release-14-0.2.noarch has missing requires of system-release >= ('0', '14', None)
telepathy-feed-0.13-7.fc12.x86_64 has missing requires of libtelepathy.so.2()(64bit)
Comment 15 Jindrich Novy 2010-07-14 01:35:07 EDT
Note what the log says:

Error: Package: compat-db-4.7.25-4.fc13.x86_64 (updates-testing)
           Requires: compat-db45(x86-64) = 4.5.20-4.fc13
>>>        Installed: compat-db45-4.5.20-5.fc10.x86_64 (@fedora/11)  <<<
           Available: compat-db45-4.5.20-2.fc13.x86_64 (fedora)
           Available: compat-db45-4.5.20-3.fc13.x86_64 (updates)
           Available: compat-db45-4.5.20-4.fc13.x86_64 (updates-testing)

It seems your system compat-db45 package comes from Fedora 10 (!). I bumped the release to compat-db45-4.5.20-6 in F13 so that it allows you to update to F13, i.e. update path isn't broken because of this.

Next update is on its way.
Comment 16 Fedora Update System 2010-07-14 02:14:02 EDT
compat-db-4.7.25-15.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/compat-db-4.7.25-15.fc13
Comment 17 Alex Lancaster 2010-07-14 16:24:51 EDT
(In reply to comment #15)
> Note what the log says:
> 
> Error: Package: compat-db-4.7.25-4.fc13.x86_64 (updates-testing)
>            Requires: compat-db45(x86-64) = 4.5.20-4.fc13
> >>>        Installed: compat-db45-4.5.20-5.fc10.x86_64 (@fedora/11)  <<<
>            Available: compat-db45-4.5.20-2.fc13.x86_64 (fedora)
>            Available: compat-db45-4.5.20-3.fc13.x86_64 (updates)
>            Available: compat-db45-4.5.20-4.fc13.x86_64 (updates-testing)
> 
> It seems your system compat-db45 package comes from Fedora 10 (!). I bumped the
> release to compat-db45-4.5.20-6 in F13 so that it allows you to update to F13,
> i.e. update path isn't broken because of this.

Ah, I see that the compat-db4[567] packages inherits the release number from the main package, that's the problem.  This means that you'll have this problem every time the main package is reset to 1 in a new major release, since the subpackages will automatically have a smaller NVR.  How to work around this in general?
Comment 18 Jindrich Novy 2010-07-14 16:55:19 EDT
There are couple of solutions to this actually:

a) bump Epoch with every major release
b) keep the Release number increasing even if the new major release is out
c) use only the major version for all the compat-db4? packages (so you could have a package like compat-db45-4.7.25-10)

The most general solution seems to be c). But one cannot figure out the exact compat version from the NVR then...
Comment 19 Fedora Update System 2010-07-14 19:05:26 EDT
compat-db-4.7.25-15.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update compat-db'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/compat-db-4.7.25-15.fc13
Comment 20 Alex Lancaster 2010-07-14 20:39:58 EDT
(In reply to comment #18)
> There are couple of solutions to this actually:
> 
> a) bump Epoch with every major release
> b) keep the Release number increasing even if the new major release is out
> c) use only the major version for all the compat-db4? packages (so you could
> have a package like compat-db45-4.7.25-10)
> 
> The most general solution seems to be c). But one cannot figure out the exact
> compat version from the NVR then...    

I'd vote for (b) I think since (c) has the problem you just mentioned and Epoch's are major pain.
Comment 21 Grant Williamson 2010-07-19 01:47:56 EDT
compat-db-4.7.25-15.fc13 would appear to update and resolve the issue on my system.
Comment 22 Fedora Update System 2010-08-26 13:40:04 EDT
compat-db-4.7.25-17.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/compat-db-4.7.25-17.fc14
Comment 23 Fedora Update System 2010-09-04 01:21:15 EDT
compat-db-4.7.25-17.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.