Bug 59098 - RFE: New version of Tix
RFE: New version of Tix
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tcltk (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
David Lawrence
http://tix.sourceforge.net/
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-30 17:55 EST by Need Real Name
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-16 03:39:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-30 17:55:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en]C-{C-UDP; EBM-FUJITSU}  (Win98; U)

Description of problem:
Tix has a new release at http://tix.sourceforge.net.
The latest release is tix-8.1.3.

Could you synchronize your release with this version, and
let me know if there are any problems. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Download from http://tix.sourceforge.net/
2.configure, make, install as usual
3.See if all outstanding bugs are fixed.
	

Additional info:

I'm having a little difficulty figuring out RedHat's releases/packages
for tix. I would recommend against shipping the tix-8.2.0 beta
(there's b3 currently on tix.sourceforge.net): tix-8.1.3 is more reliable
when used from Python and Ruby. I don't  expect 8.2.0 to go final until tk8.4
has been out for a while - there's till ongoing work integrating Tix with Python.
Comment 1 Need Real Name 2002-02-07 13:18:04 EST
It looks like RH went to tix-8.2.0b1 in RH 7.1, but I think that's a mistake. I don't think
tix-8.2.0 (now b3) is ready for prime time, especially with Python 2.x.

There are 3 patches on tix-8.2.0b1, all of which I have questions about:

a) dirtree-patch I believe corresponds to the bugzilla report
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=45570
I have contributed a followup to say I think it was a python 2.1
Tix.py problem that is no longer true with a fixed Tix.py (in tix-8.1.3).

b) perf-patch which is based on an analysis done in 1999 on Tix 4.1.x and tk8.0
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=2332
and AFAIK stopped being a problem in tix-8.1.1/tk-8.3.1.

c) makecfg-patch which hacks configure directly instead of getting the
spec file to use configure to change the CFLAGS or fixing configure.in 

 It also takes the tix version number out of the .so file name which I think is 
dangerous, because I'm not sure tix 8.1.x and tix 8.2.x libraries will be 
binary interchangeable - I certainly have not tried this. IMHO it would be better
to use the .spec file to make a symlink.

Can you check to see if these patches are still needed?

Comment 2 Jens Petersen 2002-08-14 05:29:21 EDT
Thanks for your report.

I'm having trouble getting tix-8.1.3 to build cleanly in our setup
so far.  I'll try again before too long.
Comment 3 Jens Petersen 2002-10-27 11:11:51 EST
The next rawhide package release should contain 8.1.3.  Thanks.
Comment 4 Jens Petersen 2002-12-03 09:37:37 EST
Also the patches in mention are no longer being applied.
Comment 5 Jens Petersen 2002-12-10 20:22:03 EST
tix-1:8.1.3 should be in rawhide before too long.
Comment 6 Jens Petersen 2003-01-16 03:39:10 EST
tix-8.1.4-84 should be in rawhide soon.

Note You need to log in before you can comment on or make changes to this bug.