Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 590984 - yumBackend.py takes 100% of the cpu forever(?)
yumBackend.py takes 100% of the cpu forever(?)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 03:18 EDT by Aner Gusic
Modified: 2014-01-21 18:14 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-19 08:54:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aner Gusic 2010-05-11 03:18:34 EDT
Description of problem:
Sometimes, yumBackend.py fails in a way that it takes 90-100% of the cpu and never seems to exit.

Version-Release number of selected component (if applicable):
yum-utils-1.1.26-1.fc12.noarch
yum-3.2.27-2.fc12.noarch
yum-presto-0.6.2-1.fc12.noarch
anaconda-yum-plugins-1.0-5.fc12.noarch
yum-metadata-parser-1.1.2-14.fc12.i686
PackageKit-yum-plugin-0.5.7-2.fc12.i686
PackageKit-yum-0.5.7-2.fc12.i686


How reproducible:
Don't turn of your laptop for 2-4 days and this will happen.

 
Actual results:
yumBackend.py takes all the cpu and never exits.

Expected results:
yumBackend.py runs minutes not hours.

Additional info:
Could this bug be triggered by being behind a firewall? "yum update/install" works however. This is the config line in the yum.conf:
proxy=http://192.168.8.2:80
Comment 1 seth vidal 2010-05-11 10:24:13 EDT
I'm pretty sure this is the metadata reget bug.



download this yum
http://koji.fedoraproject.org/koji/buildinfo?buildID=166139

and see if it goes away.
Comment 2 Aner Gusic 2010-05-11 10:47:08 EDT
Thanks, updating as we speak. Will get back in a couple of days.
Comment 3 Aner Gusic 2010-05-19 05:46:46 EDT
The bug has not occured since I updated yum.  I suggest we close the bug, I'll make a new comment should the problem reoccur.

Thanks for the help

Note You need to log in before you can comment on or make changes to this bug.