Bug 591007 - [abrt] crash detected in SwNumRule::SetInvalidRule
[abrt] crash detected in SwNumRule::SetInvalidRule
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:272b830aa0b62803a0c3fbb050d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 03:55 EDT by Tanmay Upadhyay
Modified: 2010-05-18 07:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 07:39:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (48.58 KB, text/plain)
2010-05-11 03:55 EDT, Tanmay Upadhyay
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 106939 None None None Never
OpenOffice.org 111681 None None None Never

  None (edit)
Description Tanmay Upadhyay 2010-05-11 03:55:12 EDT
abrt detected a crash.

Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/swriter.bin -writer file:///data/marvell/plugd/guruplugD+cam/EI_Marvell_PlugD-IPCamera_SoW_v0.9.doc
component: openoffice.org
executable: /usr/lib/openoffice.org3/program/swriter.bin
kernel: 2.6.31.5-127.fc12.i686.PAE
package: openoffice.org-writer-1:3.1.1-19.14.fc12
rating: 4
reason: Process was terminated by signal 11
Comment 1 Tanmay Upadhyay 2010-05-11 03:55:17 EDT
Created attachment 413060 [details]
File: backtrace
Comment 2 Caolan McNamara 2010-05-11 04:16:34 EDT
Are you able to reproduce this ? It looks like exporting a given document to .odt, do you have the original document ?
Comment 3 Tanmay Upadhyay 2010-05-11 04:32:00 EDT
(In reply to comment #2)
> Are you able to reproduce this ? It looks like exporting a given document to
> .odt, do you have the original document ?    

No, I can't reproduce it now. But on that particular day, it happened a couple of times. Unfortunately my ABRT was not working (because a few packages were missing) that day. I just set it up today and thought to report this crash.

Actually I was comparing two '.doc' files. It happened when my machine was idle. When it happened for the first time I was away from the machine and it was locked automatically. When I unlocked it, I found OpenOffice had disappeared. The next time it happened when I was discussing with my colleague and machine was left idle. However, it wasn't locked by the time.

I wasn't sure about why this happened or if it has anything to do with OpenOffice/Linux/'.doc' file itself. But I thought the crash info might tell you guys something about. OpenOffice has never crashed after that.

Hope this helps.
Comment 4 David Tardon 2010-05-13 03:46:14 EDT
OK, then it was automatic save of the combined document that trigerred the crash. Do you happen to have these two documents yet? If yes, you can try an experiment: do the comparison just like before and save the resulting document as a new document with ODT format. In the case writer crashed, could you attach the two documents here?
Comment 5 Caolan McNamara 2010-05-18 07:39:57 EDT
Can't reproduce, could workaround though. Submitted possible patch upstream for consideration.

Note You need to log in before you can comment on or make changes to this bug.