Bug 591008 - abrt daemon crashes and gui unresponsive
abrt daemon crashes and gui unresponsive
Status: CLOSED DUPLICATE of bug 580899
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 03:55 EDT by Simon Goodall
Modified: 2015-02-01 17:52 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-11 04:12:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Goodall 2010-05-11 03:55:51 EDT
Description of problem:

My abrt-gui has stopped working. The screen takes a long time to draw/redraw and is completely unresponsive.

My messages file fills up with the following message repeated frequently while the gui app is running.

May 11 08:13:23 blink abrtd: warning: /proc/sys/kernel/core_pattern was already set to run a crash analyser (|/usr/libexec/abrt-hook-ccpp /var/cache/abrt %p %s %u %c), abrt may interfere with it
May 11 08:13:23 blink abrtd: Registered Analyzer plugin 'CCpp'
May 11 08:13:23 blink abrtd: Registered Analyzer plugin 'Kerneloops'
May 11 08:13:23 blink abrtd: Registered Action plugin 'KerneloopsScanner'
May 11 08:13:23 blink abrtd: Registered Reporter plugin 'KerneloopsReporter'
May 11 08:13:23 blink abrtd: Registered Analyzer plugin 'Python'
May 11 08:13:23 blink abrtd: Checking for unsaved crashes (dirs to check:4)
May 11 08:13:23 blink abrtd: Registered Database plugin 'SQLite3'
May 11 08:13:23 blink abrtd: invalid number ''

It also appears that my daemon has crashed, and continues to crash when restarted.

E.g. when my nautilus crashed, my log file showed;

May 11 07:42:18 blink kernel: nautilus[29671]: segfault at c ip 0811d200 sp bfb0a620 error 4 in nautilus[8045000+1da000]
May 11 07:42:18 blink abrt[32766]: abrt daemon is not running. If it crashed, /proc/sys/kernel/core_pattern contains a stale value, consider resetting it to 'core'

Following ths instructions and setting the value to core makes no difference to the gui or daemon.



Version-Release number of selected component (if applicable):
abrt-1.1.0-1.fc13.i686

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Karel Klíč 2010-05-11 04:12:33 EDT
Hi Simon,

Thank you for the report.

Workaround for this problem is to remove the contents of /var/cache/abrt (deletes all your saved crashes).

*** This bug has been marked as a duplicate of bug 580899 ***

Note You need to log in before you can comment on or make changes to this bug.