Bug 591019 - [abrt] crash in system-config-kdump-2.0.2.1-11.el6: system-config-kdump.py:1510:cmdline_changed:ValueError: invalid literal for float(): aut
[abrt] crash in system-config-kdump-2.0.2.1-11.el6: system-config-kdump.py:15...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-kdump (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Roman Rakus
Michal Nowak
abrt_hash:45d88776
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 04:45 EDT by Michal Nowak
Modified: 2014-01-12 19:11 EST (History)
4 users (show)

See Also:
Fixed In Version: system-config-kdump-2.0.2.1-14.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 15:52:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (637 bytes, text/plain)
2010-05-11 04:45 EDT, Michal Nowak
no flags Details

  None (edit)
Description Michal Nowak 2010-05-11 04:45:32 EDT
abrt 1.1.0 detected a crash.

architecture: x86_64
cmdline: python /usr/share/system-config-kdump/system-config-kdump.py
component: system-config-kdump
executable: /usr/share/system-config-kdump/system-config-kdump.py
kernel: 2.6.32-22.el6.x86_64
package: system-config-kdump-2.0.2.1-11.el6
reason: system-config-kdump.py:1510:cmdline_changed:ValueError: invalid literal for float(): aut
release: Red Hat Enterprise Linux release 6.0 Beta (Santiago)

backtrace
-----
system-config-kdump.py:1510:cmdline_changed:ValueError: invalid literal for float(): aut

Traceback (most recent call last):
  File "/usr/share/system-config-kdump/system-config-kdump.py", line 1523, in reset_cmdline
    self.cmdline_changed(self.command_line_entry)
  File "/usr/share/system-config-kdump/system-config-kdump.py", line 1510, in cmdline_changed
    self.kdump_mem_spin_button.set_value(float(value))
ValueError: invalid literal for float(): aut

Local variables in innermost frame:
gtk_entry: <gtk.Entry object at 0x1d454b0 (GtkEntry at 0x1e60510)>
self: <__main__.MainWindow instance at 0x1c4b7a0>
args: ()
value: 'aut'

How to reproduce
-----
1.refreshed frub kernel line
2.Apply
3.inserter 3-4 times password

I thought s-c-kdump is closed but this crash appeared after few seconds.
Comment 1 Michal Nowak 2010-05-11 04:45:35 EDT
Created attachment 413070 [details]
File: backtrace
Comment 3 RHEL Product and Program Management 2010-05-11 06:33:02 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Radek Novacek 2010-05-14 11:04:19 EDT
I'm not able to reproduce the bug with step from comment #1. But I reproduced similar issue when I manually changed command line options on Expert settings card. I changed from "crashkernel=192M" to "crashkernel=aa192M" and change focus to another widget, then the error appears in terminal (no crash). 

How should s-c-kdump react on that? Error message? Silently change that to some valid value? Something else?
Comment 5 Roman Rakus 2010-05-19 11:05:00 EDT
Possible values are
1) auto
2) X@Y
3) X

where auto is string
X is numeric value with optional M suffix
Y is optional value with optional M suffix

I will add check for the above possibilities.
Comment 7 Roman Rakus 2010-05-19 15:04:38 EDT
Should be fixed in system-config-kdump-2.0.2.1-14.el6
Comment 10 releng-rhel@redhat.com 2010-07-02 15:52:48 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.