Bug 591060 - Delayed message delivery while new cluster node is joining
Delayed message delivery while new cluster node is joining
Status: CLOSED DUPLICATE of bug 617639
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.2
All Linux
high Severity high
: 1.3
: ---
Assigned To: mick
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 07:00 EDT by Gordon Sim
Modified: 2010-07-23 11:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-23 11:45:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Sim 2010-05-11 07:00:42 EDT
Description of problem:

It is reported that in a two node cluster there are around 700 exchange and 700 queues, however messages are being actively routed through only one exchange to only one queue. If one node is stopped and restarted, the process of rejoining the cluster appears to prevent the delivery of messages for up to a minute. qpid-queue-stats shows a long dip in enqueue/dequeue rates during this time 

Version-Release number of selected component (if applicable):

1.2
Comment 2 Frantisek Reznicek 2010-06-14 05:36:51 EDT
Could you possibly add information on which revision/package set is the issue seen, please?
Comment 3 Gordon Sim 2010-06-14 05:49:46 EDT
Issue was reported as being on 1.2 however the customer does have a hotfix in play so it is most likely including that (i.e. probably qpidd-0.5.752581-36_cust).
Comment 4 mick 2010-07-23 11:45:47 EDT
I'm closing this -- it is superseded by my report of bz617639 - slowness in MRG brokers joining new cluster after kill -9 of previous members  ( submitted to openais/corosync ).

*** This bug has been marked as a duplicate of bug 617639 ***

Note You need to log in before you can comment on or make changes to this bug.