Bug 591091 - No junit4 package on ppc64
No junit4 package on ppc64
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: junit4 (Show other bugs)
6.0
ppc64 Linux
low Severity medium
: rc
: ---
Assigned To: Alexander Kurtakov
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 08:19 EDT by Steve Traylen
Modified: 2012-06-04 11:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-15 12:21:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Traylen 2010-05-11 08:19:14 EDT
I wanted to build bouncycastle for EPEL6.

It seems there is no junit4 package in RHEL6beta ppc64.

Is this intentional?

Steve.
Comment 1 Alexander Kurtakov 2010-05-11 08:40:04 EDT
It's a noarch package. See ftp://ftp.redhat.com/pub/redhat/rhel/beta/6/i386/os/Packages/junit4-4.5-5.3.el6.noarch.rpm 
I don't know why it didn't make it to ppc64.
Comment 2 Steve Traylen 2010-05-11 08:49:10 EDT
It needs to be in ppc64 properly to permit EPEL packages on ppc64 to use it.

Steve.
Comment 3 Dennis Gregorovic 2010-05-11 09:08:44 EDT
junit4 is only being pulled into the tree as a dependency of eclipse-jdt, and the eclipse stack is only included on x86_64 and i386.  Perhaps junit4 could be copied into EPEL on ppc64?
Comment 5 RHEL Product and Program Management 2010-05-11 10:20:25 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Dennis Gilmore 2010-05-13 13:18:00 EDT
Dennis, Due to the way koji works we can not provide packages in epel for only one architecture and we cant provide it for all.

RHEL-5 epel has no ppc support.  Id like to promote ppc64 java support but perhaps we have to limit it for EL-6
Comment 7 Andrew Overholt 2010-06-29 13:27:01 EDT
Can the component be changed to koji or EPEL or something?
Comment 8 Bill Nottingham 2010-06-29 13:34:11 EDT
Dennis - can't someone build an exclusivearch ppc junit in EPEL?
Comment 9 Dennis Gilmore 2010-06-29 14:08:57 EDT
We cant build packages for just one arch in EPEL, if we do the package will only then be available for the epel built arches. the only way to do it would be kinda messy.  but have say junit-epel which is ppc64 only and provides all the junit provides.

there is not a clean easy way to do this other than for Red HAt to provide the same set of rpms across all arches. even if they are base on some arches and in optional on others.
Comment 11 RHEL Product and Program Management 2010-07-15 10:58:38 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 12 Mattias Ellert 2010-07-15 11:20:22 EDT
This bug should have been labelled as priority: urgent, severity: urgent from the start, and should have been fixed the day after it was reported. I don't get why it is not solved yet more than two months after it was reported.
Comment 13 Bill Nottingham 2010-07-15 12:21:29 EDT
The solution for this is to build junit4 in EPEL for the arches that need it. (If that requires building it on all arches, so be it.)
Comment 14 Steve Traylen 2010-07-20 16:05:08 EDT
The other solution is just ExcludeArch ppc64 for bouncycastle. I have zero
interest in seeing a ppc64 build and if redhat just want to drop this stack
on ppc64 so be it.

Steve.

Note You need to log in before you can comment on or make changes to this bug.