Bug 591095 - after rotation selection still appears in the previous place
Summary: after rotation selection still appears in the previous place
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evince   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Caolan McNamara
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-11 12:42 UTC by Vladimir Benes
Modified: 2017-12-06 11:21 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 11:21:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rotated document with highlighted selection in a wrong place (82.41 KB, image/png)
2010-05-11 12:42 UTC, Vladimir Benes
no flags Details

Description Vladimir Benes 2010-05-11 12:42:57 UTC
Created attachment 413129 [details]
rotated document with highlighted selection in a wrong place

Description of problem:
after rotation of document via Edit -> Rotate Left if I select text, the highlight appears in the previous space and after the second click also the text appears there. see the attachment for details

Version-Release number of selected component (if applicable):
evince-2.28.2-6.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.open text document in evince
2.rotate it left via edit->rotate left
3.select text 
  
Actual results:
text is selected in previous place

Expected results:
text should be highlighted and selected in the right place

Additional info:
copy and paste works as expected so only visual aspect is affected

Comment 1 RHEL Product and Program Management 2010-05-11 13:12:14 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Marek Kašík 2010-05-14 09:34:19 UTC
Hi,

how did you select the text. Was it by double-clicking on the text?

Marek

Comment 3 Vladimir Benes 2010-05-17 13:20:53 UTC
you need two or tree clicks to select or to show text in highligh.
Correction: The original text was too simple now I see that you have to click to original pre-rotate position to select the text

Comment 4 Marek Kašík 2010-05-17 13:50:42 UTC
Hi,

selecting text in rotated documents should not be possible. It is not implemented in evince yet. There is an upstream bug https://bugzilla.gnome.org/show_bug.cgi?id=583552 for this.
I filled a bug for disabling the incorrect selection (bug #592963).
I'm changing version of this bug to RHEL 6.1.

Regards

Marek

Comment 7 RHEL Product and Program Management 2011-01-07 15:47:04 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 9 Jan Kurik 2017-12-06 11:21:57 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.