Bug 591096 - KNetworkManager appears twice in F13 KDE menus
Summary: KNetworkManager appears twice in F13 KDE menus
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-plasma-networkmanagement   
(Show other bugs)
Version: 13
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-11 12:45 UTC by Adam Williamson
Modified: 2011-02-22 14:12 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-22 14:12:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Williamson 2010-05-11 12:45:06 UTC
KNetworkManager appears twice in the F13 RC2 KDE menus, in 'System' and 'Utilities'.

This is technically a failure of the 'desktop menus' validation test:
https://fedoraproject.org/wiki/QA:Testcase_desktop_menus . As we don't consider
the desktop validation tests to be release blocking for anything but the
default desktop in F13, not nominating this as a release blocker. For future
releases we would consider this kind of issue release blocking if the same
criteria from desktop team are applied to KDE, but we could adjust the criteria
applied to KDE if KDE team wouldn't consider such an issue to be a blocker.

Comment 1 James Laska 2010-05-18 16:54:12 UTC
Looks like the menu .desktop file (/usr/share/applications/kde4/knetworkmanager.desktop) is configured as such.

Categories=Utility;TrayIcon;System;Applet;
           ^^^^^^^          ^^^^^^

As Adam notes, it's still unclear whether KDE abides by this same criteria around duplicate entries in the menus.

Comment 2 Steven M. Parrish 2010-06-05 01:39:54 UTC
This bug has been triaged



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Fedora Admin XMLRPC Client 2010-09-11 23:52:05 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Rex Dieter 2011-02-22 14:12:35 UTC
Resolved now that we've deprecated knetworkmanager in favor of kde-plasma-networkmanagement


Note You need to log in before you can comment on or make changes to this bug.