This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 591142 - virt-inspector should give an error for unrecognized disk images
virt-inspector should give an error for unrecognized disk images
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
high Severity high
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 10:32 EDT by Richard W.M. Jones
Modified: 2011-07-14 15:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-14 15:07:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2010-05-11 10:32:48 EDT
Description of problem:

If you run virt-inspector on something which isn't a disk image (or is blank
or random) then it runs and produces no output and no error.

Version-Release number of selected component (if applicable):

1.3.11

How reproducible:

Always.

Steps to Reproduce:
1. virt-inspector /dev/zero
2. echo $?
3.
  
Actual results:

Status is 0 and no error.

Expected results:

An error message.

Additional info:
Comment 1 Richard W.M. Jones 2010-05-12 13:17:31 EDT
Patch posted upstream:

https://www.redhat.com/archives/libguestfs/2010-May/msg00059.html

$ virt-inspector /dev/zero 
No operating system could be detected inside this disk image.

This may be because the file is not a disk image, or is not a virtual machine
image, or because the OS type is not understood by virt-inspector.

If you feel this is an error, please file a bug report including as much
information about the disk image as possible.
$ echo $?
2
Comment 2 Fedora Update System 2010-05-14 15:12:37 EDT
libguestfs-1.2.6-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libguestfs-1.2.6-1.fc13
Comment 3 Fedora Update System 2010-05-17 08:28:01 EDT
libguestfs-1.2.7-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libguestfs-1.2.7-1.fc12
Comment 4 Fedora Update System 2010-05-17 08:47:50 EDT
libguestfs-1.2.7-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.2.7-1.el5
Comment 5 Fedora Update System 2010-05-17 09:00:16 EDT
libguestfs-1.2.7-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libguestfs-1.2.7-2.fc13
Comment 6 Fedora Update System 2010-05-21 07:33:30 EDT
libguestfs-1.2.7-2.fc13.1 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libguestfs-1.2.7-2.fc13.1

Note You need to log in before you can comment on or make changes to this bug.