Bug 591177 - RHQ 3.0.0.B05 not updating JBoss AS 6.0.0.M3 status
RHQ 3.0.0.B05 not updating JBoss AS 6.0.0.M3 status
Status: CLOSED UPSTREAM
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
3.0.0
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 11:37 EDT by Marek Goldmann
Modified: 2010-07-19 20:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-19 20:08:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing a green JBoss AS 6.0.0.M3 Resource w/ successfully collected traits (88.58 KB, image/png)
2010-05-11 14:24 EDT, Ian Springer
no flags Details

  None (edit)
Description Marek Goldmann 2010-05-11 11:37:33 EDT
Description of problem:

After JBoss AS 6 import, updating status is not possible. JBoss AS is always in state DOWN.

http://gist.github.com/397426

Version-Release number of selected component (if applicable):

RHQ 3.0.0.B05
JBoss AS 6.0.0.M3

How reproducible:
Always.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

JBoss AS imported and NOT updating status.

Expected results:

JBoss AS imported and updating status.

Additional info:
Comment 1 Marek Goldmann 2010-05-11 11:46:24 EDT
Forgotten JAR is jboss-classpool.jar

[root@ip-10-244-158-225 lib]# jar tvf jboss-classpool.jar | grep ClassPoolRepositoryCallback
   254 Wed Apr 07 15:22:28 EDT 2010 org/jboss/classpool/spi/ClassPoolRepositoryCallback.class
Comment 2 Ian Springer 2010-05-11 12:35:08 EDT
Here's the relevant portion of the stack trace from the gist link for easier reference:

Caused by: java.lang.NoClassDefFoundError: org/jboss/classpool/spi/ClassPoolRepositoryCallback
at org.jboss.aop.AspectManager.initManager(AspectManager.java:267)
at org.jboss.aop.AspectManager.instance(AspectManager.java:246)
at org.jboss.aop.AspectManager.instance(AspectManager.java:235)
at org.jboss.aop.proxy.ProxyFactory.createProxyCtClass(ProxyFactory.java:150)
at org.jboss.aop.proxy.ProxyFactory.createProxyClass(ProxyFactory.java:119)
at org.jboss.aop.proxy.ProxyFactory.createInterfaceProxy(ProxyFactory.java:96)
at org.jboss.aop.proxy.MarshalledInterfaceProxy.readResolve(MarshalledInterfaceProxy.java:72)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:616)
at java.io.ObjectStreamClass.invokeReadResolve(ObjectStreamClass.java:1078)
at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1779)
at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1346)
at java.io.ObjectInputStream.readObject(ObjectInputStream.java:368)
at java.rmi.MarshalledObject.get(MarshalledObject.java:159)
at org.jnp.interfaces.MarshalledValuePair.get(MarshalledValuePair.java:72)
at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:771)
at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:688)
at javax.naming.InitialContext.lookup(InitialContext.java:409)
at org.rhq.plugins.jbossas5.connection.AbstractProfileServiceConnectionProvider.lookup(AbstractProfileServiceConnectionProvider.java:81)
at org.rhq.plugins.jbossas5.connection.RemoteProfileServiceConnectionProvider.doConnect(RemoteProfileServiceConnectionProvider.java:108)
at org.rhq.plugins.jbossas5.connection.RemoteProfileServiceConnectionProvider.doConnect(RemoteProfileServiceConnectionProvider.java:43)
at org.rhq.plugins.jbossas5.connection.AbstractProfileServiceConnectionProvider.connect(AbstractProfileServiceConnectionProvider.java:42)
at org.rhq.plugins.jbossas5.ApplicationServerComponent.connectToProfileService(ApplicationServerComponent.java:401)
at org.rhq.plugins.jbossas5.ApplicationServerComponent.start(ApplicationServerComponent.java:195)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:616)
at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:525)
... 5 more
Caused by: java.lang.ClassNotFoundException: org.jboss.classpool.spi.ClassPoolRepositoryCallback
at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:319)
at org.rhq.core.pc.plugin.PluginClassLoader.loadClass(PluginClassLoader.java:63)
at java.lang.ClassLoader.loadClass(ClassLoader.java:264)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:332)
... 36 more
Comment 3 Ian Springer 2010-05-11 14:22:53 EDT
I got AS 6.0.0.M3 working by adding lib/jboss-classpool.jar, along with lib/jboss-classpool-scoped.jar to the list of client jars used by the jboss-as-5 plugin to connect to the AS instance. Screenshot of my green M3 Resource attached.

The fix is in the RHQ master branch - rev 9d65333.
Comment 4 Ian Springer 2010-05-11 14:24:11 EDT
Created attachment 413215 [details]
screenshot showing a green JBoss AS 6.0.0.M3 Resource w/ successfully collected traits
Comment 5 Ian Springer 2010-05-11 14:48:15 EDT
See also: https://jira.jboss.org/jira/browse/JBAS-8023
Comment 7 Corey Welton 2010-07-19 20:08:10 EDT
QA Closing - rhq upstream bug.  This bug is presumed to be fixed in the upstream branch.  If this is not the case, this bug can be reopened.

Note You need to log in before you can comment on or make changes to this bug.