Bug 591198 - Need flag to enable quorum mode for even split stretch clusters
Need flag to enable quorum mode for even split stretch clusters
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.6
All Linux
low Severity medium
: rc
: ---
Assigned To: Christine Caulfield
Cluster QE
: FutureFeature
Depends On: 591197
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 12:12 EDT by Perry Myers
Modified: 2010-05-11 13:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 591197
Environment:
Last Closed: 2010-05-11 13:26:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2010-05-11 12:12:34 EDT
+++ This bug was initially created as a clone of Bug #591197 +++

Description of problem:
Today a 2 node cluster can be used in a stretch cluster configuration using cman 2 node mode, which effectively lets both nodes win and uses a fence race to break the tie.  If the fencing network is the same as the heartbeat network, then this means that the admin chooses which node wins by running fence_ack_manual to break the tie.

For 2x2, 3x3... stretch clusters we have the same problem but 2 node mode cannot work here.  Instead we need to allow a mode where quorum can be maintained by expected_votes/2 instead of (expected_votes/2)-1

Normally in a non-stretch environment qdisk would be used to handle this number of nodes failing, but qdisk cannot be used across a stretch cluster since it cannot be used with storage replication technologies and the qdisk cannot be located at just a single site.

So suggest is to create a cluster.conf option to enable 'stretch cluster mode' which can be used with all two site stretch clusters with an even node count.  (Note, stretch clusters by definition have to have an even node count)  This new option would change the number of required votes as described above, and can _only_ be used on a stretch cluster configuration and requires that the customer get engineering review of their configuration/architecture.
Comment 1 Perry Myers 2010-05-11 13:26:11 EDT
Further discussion uncovered that this cannot be done because a temporary ISL failure will result in each side having a fencing race which will then obliterate the cluster.  So closing this as CANTFIX

Note You need to log in before you can comment on or make changes to this bug.