Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 591215 - (CVE-2010-3438) CVE-2010-3438 perl-POE-Component-IRC: arbitrary IRC command execution due to insufficient stripping of CR/LF
CVE-2010-3438 perl-POE-Component-IRC: arbitrary IRC command execution due to ...
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
public=20100510,reported=20100511,sou...
: Security
: 663801 (view as bug list)
Depends On: 591216 594464
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 12:50 EDT by Vincent Danen
Modified: 2010-12-17 10:36 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-17 01:08:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vincent Danen 2010-05-11 12:50:50 EDT
A vulnerability was reported [1] to Debian for POE::Component::IRC, where it did not remove carriage returns and line feeds.  This affects tools or IRC bots using the perl module, and can be used to execute arbitrary IRC commands by passing an argument such as "some text\rQUIT" to the 'privmsg' handler, which would cause the client to disconnect from the server.

Upstream has fixed [2],[3],[4] the issue and it is included in the current 6.32 release.

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=581194
[2] http://github.com/bingos/poe-component-irc/commit/4f46c29376359b3d7c5b5cd400115103fdef9ca8
[3] http://github.com/bingos/poe-component-irc/commit/675f55cd40ceebbc1bd2f309311a066bed41d869
[4] http://github.com/bingos/poe-component-irc/commit/9e2a01af6a908f9c1c97431bcbc5f483a7a99e2f
Comment 1 Vincent Danen 2010-05-11 12:52:10 EDT
Created perl-POE-Component-IRC tracking bugs for this issue

Affects: fedora-all [bug 591216]
Comment 2 Fedora Update System 2010-05-20 14:37:57 EDT
perl-POE-Component-IRC-6.14-2.fc13.1 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/perl-POE-Component-IRC-6.14-2.fc13.1
Comment 3 Fedora Update System 2010-05-20 14:38:06 EDT
perl-POE-Component-IRC-6.14-1.fc12.1 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/perl-POE-Component-IRC-6.14-1.fc12.1
Comment 4 Fedora Update System 2010-05-28 14:07:27 EDT
perl-POE-Component-IRC-6.14-1.fc12.1 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2010-05-28 14:08:20 EDT
perl-POE-Component-IRC-6.14-2.fc13.1 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Iain Arnell 2010-12-17 01:08:44 EST
This is fixed in all supported versions of Fedora.
Comment 7 Iain Arnell 2010-12-17 01:10:07 EST
*** Bug 663801 has been marked as a duplicate of this bug. ***
Comment 8 Vincent Danen 2010-12-17 10:36:41 EST
This is CVE-2010-3438.

Note You need to log in before you can comment on or make changes to this bug.