Bug 591233 - Time/Date applet changes size, depending on the list of Locations
Time/Date applet changes size, depending on the list of Locations
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-panel (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
: Reopened
Depends On:
Blocks: 756082
  Show dependency treegraph
 
Reported: 2010-05-11 13:31 EDT by Jay Turner
Modified: 2017-12-06 05:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 05:15:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Clock applet before hovering (115.32 KB, image/png)
2010-05-11 13:31 EDT, Jay Turner
no flags Details
Clock applet after hovering (115.35 KB, image/png)
2010-05-11 13:32 EDT, Jay Turner
no flags Details

  None (edit)
Description Jay Turner 2010-05-11 13:31:12 EDT
Created attachment 413208 [details]
Clock applet before hovering

Description of problem:
A bit of fit-and-finish here.  The issue does not impact the functionality of the applet, but falls into the "dumb bugs" category as it gives off a decidedly unprofessional feel.

Version-Release number of selected component (if applicable):
2.28.0-21.el6 (although appears to happen with earlier versions of the applet as well.)

How reproducible:
Always

Steps to Reproduce:
1. Configure at least one location which will appear as a different day
2. Move the cursor down the list, which should force the "Set" button to appear
  
Actual results:
When the set button appears beside one of the long strings (showing time, day and TZ offset) the applet will resize itself wider, sometimes forcing the left side of the applet off of the display.

Expected results:
The applet doesn't resize.  Don't know if the way to achieve this is to make the applet wider during initialization or cut down on the "day" display (showing "Wed" instead of "Wednesday" for example.)

Additional info:
After looking at this on a few systems, I'm not sure how widespread the problem really is . . . might only happen when for "Wednesday" due to the character-length.
Comment 1 Jay Turner 2010-05-11 13:32:18 EDT
Created attachment 413210 [details]
Clock applet after hovering

Although the "Set" button is not visible, note that the applet has stretched off the left side of the screen.
Comment 4 Ray Strode [halfline] 2010-06-08 13:08:30 EDT
We should consider fixing this for GA, but clearly should not block GA for this bug. Changing from blocker to exception.

devack.
Comment 10 RHEL Product and Program Management 2010-11-30 12:55:08 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 13 Suzanne Yeghiayan 2011-03-28 17:08:22 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains 
unresolved, it has been rejected as it is not proposed as an 
exception or blocker.

Red Hat invites you to ask your support representative to 
propose this request, if appropriate and relevant, in the 
next release of Red Hat Enterprise Linux.
Comment 15 RHEL Product and Program Management 2011-07-05 19:40:59 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 20 Suzanne Yeghiayan 2012-03-07 16:27:15 EST
This request was evaluated by Red Hat Product Management for inclusion in the
current release of Red Hat Enterprise Linux. Because the affected component is
not scheduled to be updated in the current release, Red Hat is unfortunately
unable to address this request at this time.  It has been proposed for the next
release. If you would like it considered as an exception in the current
release, please ask your support representative.
Comment 23 RHEL Product and Program Management 2012-10-10 12:29:30 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 25 Jan Kurik 2017-12-06 05:15:55 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.