Bug 591234 - Need quorum plugin for corosync that uses network instead of disks
Summary: Need quorum plugin for corosync that uses network instead of disks
Status: CLOSED DUPLICATE of bug 614122
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cluster (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-11 17:31 UTC by Perry Myers
Modified: 2010-09-30 20:09 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-30 20:09:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Perry Myers 2010-05-11 17:31:37 UTC
Description of problem:
qdisk presently is implemented to provide additional votes per node based on ability to access shared storage.  For multi-site stretch clusters it would be better to implement this using a 3rd site node that is not a cluster member that can be accessed via network.  So if a node can get to this 3rd site via network, it gets the extra vote.

Comment 1 Ryan O'Hara 2010-08-30 20:28:44 UTC
Can this actually be done as a corosync plugin in RHEL6? I'm not convinced it can. Steve seems think that we're stuck with cman infrastructure for quorum related things until RHEL7. If this is true, the solution will need to be like qdisk but over network, with daemon receiving updates.

Comment 2 Lon Hohberger 2010-08-30 20:30:11 UTC
It's possible to use the CMAN API like we do today and implement a very simple client/server protocol to talk to the third site.

Comment 4 Lon Hohberger 2010-09-30 20:09:28 UTC

*** This bug has been marked as a duplicate of bug 614122 ***


Note You need to log in before you can comment on or make changes to this bug.