Bug 591269 - Groupinstall of "KDE-Softwarezusammenstellung" fails because of wrong PackageKit version
Summary: Groupinstall of "KDE-Softwarezusammenstellung" fails because of wrong Package...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-11 19:04 UTC by Thomas Meyer
Modified: 2014-03-17 03:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-11 19:20:26 UTC
Type: ---


Attachments (Terms of Use)

Description Thomas Meyer 2010-05-11 19:04:53 UTC
Description of problem:
sudo yum groupinstall "KDE-Softwarezusammenstellung"

results in

[...]

---> Package xorg-x11-resutils.i686 0:7.1-10.fc13 set to be updated
--> Finished Dependency Resolution
Error: Package: PackageKit-qt-0.6.3-1.fc13.i686 (fedora)
           Requires: PackageKit = 0.6.3-1.fc13
           Installed: PackageKit-0.6.4-1.fc13.i686 (@updates-testing)
           Available: PackageKit-0.6.3-1.fc13.i686 (fedora)
Error: Package: pinentry-qt-0.8.0-2.fc13.i686 (fedora)
           Requires: pinentry = 0.8.0-2.fc13
           Installed: pinentry-0.8.0-3.fc13.i686 (@updates-testing)
           Available: pinentry-0.8.0-2.fc13.i686 (fedora)
 You could try using --skip-broken to work around the problem


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Kevin Kofler 2010-05-11 19:20:26 UTC
You had updates-testing enabled. Now you have it disabled. Now you have packages which are newer than in your currently enabled respositories, which causes this kind of dependency issues. There's nothing we can do about it. Either reenable updates-testing, or wait for those updates to go stable, or downgrade the offending packages.

Comment 2 Thomas Meyer 2010-05-11 20:01:44 UTC
I didn't disable update-testing! But something seems to have done this.

rpm -qa -last shows:

google-chrome-beta-5.0.375.38-46659           Di 11 Mai 2010 18:41:11 CEST
jpackage-utils-1.7.5-3.10.fc13                Mo 10 Mai 2010 17:49:20 CEST
fedora-release-rawhide-13-1                   Mo 10 Mai 2010 17:49:19 CEST
system-config-printer-1.2.2-1.fc13            Mo 10 Mai 2010 17:49:17 CEST
authconfig-gtk-6.1.4-2.fc13                   Mo 10 Mai 2010 17:49:14 CEST
plymouth-system-theme-0.8.2-3.fc13            Mo 10 Mai 2010 17:49:13 CEST
plymouth-gdm-hooks-0.8.2-3.fc13               Mo 10 Mai 2010 17:49:13 CEST
plymouth-theme-charge-0.8.2-3.fc13            Mo 10 Mai 2010 17:49:12 CEST
gnome-settings-daemon-2.30.1-5.fc13           Mo 10 Mai 2010 17:49:09 CEST
ModemManager-0.3-13.git20100507.fc13          Mo 10 Mai 2010 17:49:06 CEST
system-config-printer-udev-1.2.2-1.fc13       Mo 10 Mai 2010 17:49:05 CEST

Is it possible that the installation of the package fedora-release-rawhide-13-1 did disable the repo?

Any ideas?

Comment 3 Rex Dieter 2010-05-11 20:08:15 UTC
now that f13 is in rc stage, updates-testing is disabled by default (it was enabled by default prior).  the price of of installing/using a pre-release.


Note You need to log in before you can comment on or make changes to this bug.