Bug 591284 - [RFE] system lock functionality
Summary: [RFE] system lock functionality
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hosts (Show other bugs)
(Show other bugs)
Version: 6.0.0
Hardware: All Linux
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature, Triaged, UserExperience
: 1215720 (view as bug list)
Depends On:
Blocks: sat-nextgen
TreeView+ depends on / blocked
 
Reported: 2010-05-11 19:42 UTC by Issue Tracker
Modified: 2018-11-14 19:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-01 14:42:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 912806 None None None Never
Red Hat Bugzilla 1319800 None None None Never

Description Issue Tracker 2010-05-11 19:42:05 UTC
Escalated to Bugzilla from IssueTracker

Comment 1 Issue Tracker 2010-05-11 19:42:06 UTC
Event posted on 04-29-2010 06:03pm EDT by spurrier

AT&T would like to submit a RFE regarding the system lock functionality:

1. Currently when a system is locked, if an administrator selects an action such as updating packages, the action itself is scheduled, instead of being denied because of the lock. The scheduled action then would be potentially executed once the lock is removed from the system.

The desired behaviour should be instead to fail to schedule the action with a message indicating that the system is locked.

2. Also, on the locking feature, when a group of systems is selected and viewed through the system set manager, is not possible to visually identify whether a system is locked or unlocked. If a visual reference to the current state of the system could be displayed it would be very useful in terms of being able to remove or add locks on a system per system basis.
This event sent from IssueTracker by cww  [SEG - Feature Request]
 issue 830013

Comment 2 Issue Tracker 2010-05-11 19:42:07 UTC
Event posted on 05-05-2010 04:57pm EDT by RFE-tool

1) Customer Name:
ATT

2) Nature Of Problem:
Currently when a system is locked, if an administrator selects an action
such as updating packages, the action itself is scheduled, instead of
being denied because of the lock. The scheduled action then would be
potentially executed once the lock is removed from the system.

3) Business Requirements Satisfied By Request:
If a system is locked, updates scheduled during the time of the lock
should not execute when the lock is removed.

4) Functional Requirements That Are Not Presently Possible:
Also, on the locking feature, when a group of systems is selected and
viewed through the system set manager, is not possible to visually
identify whether a system is locked or unlocked. If a visual reference to
the current state of the system could be displayed it would be very useful
in terms of being able to remove or add locks on a system per system basis

5) What Will Success Look Like:
The desired behaviour should be instead to fail to schedule the action
with a message indicating that the system is locked.

6) Desired Release Vehicle:
Satellite 6.0

7) Request Meets The Rhel Inclusion Criteria:
No

8) Affected Packages:
New

9) Sales Sponsor:


10) Rh Business Opportunity With Customer:


11) Status And Risk To Contract If Not Satisfied:


12) If this request is vendor specific, has the customer engaged the
partner as well?:
Not Applicable




RFE-tool assigned to issue for SEG - Feature Request.

This event sent from IssueTracker by cww  [SEG - Feature Request]
 issue 830013

Comment 3 Issue Tracker 2010-05-11 19:42:08 UTC
Event posted on 05-10-2010 10:39am EDT by vsira

Yes, the current behaviour is that the actions are indeed allowed, but not
performed until the system is unlocked. AT&T would like the action to be
denied instead.


This event sent from IssueTracker by cww  [SEG - Feature Request]
 issue 830013

Comment 6 Bryan Kearney 2016-12-02 19:24:18 UTC
*** Bug 1215720 has been marked as a duplicate of this bug. ***

Comment 7 Bryan Kearney 2017-06-01 14:42:09 UTC
Thank you for your interest in Satellite 6. We have evaluated this feature request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.