Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 591307 - SELinux is preventing /usr/bin/python "create" access .
SELinux is preventing /usr/bin/python "create" access .
Status: CLOSED DUPLICATE of bug 591290
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:18b046164cc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 16:36 EDT by David Shuman
Modified: 2010-06-29 14:04 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-11 17:21:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Shuman 2010-05-11 16:36:15 EDT
Summary:

SELinux is preventing /usr/bin/python "create" access .

Detailed Description:

SELinux denied access requested by denyhosts.py. It is not expected that this
access is required by denyhosts.py and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:denyhosts_t:s0
Target Context                system_u:system_r:denyhosts_t:s0
Target Objects                None [ unix_dgram_socket ]
Source                        denyhosts.py
Source Path                   /usr/bin/python
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.6.2-4.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-113.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.11-99.fc12.i686
                              #1 SMP Mon Apr 5 16:32:08 EDT 2010 i686 i686
Alert Count                   5
First Seen                    Thu 06 May 2010 05:11:35 PM EDT
Last Seen                     Tue 11 May 2010 11:08:56 AM EDT
Local ID                      cae643b5-b0a0-451e-af77-038fa4a13797
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1273590536.953:28425): avc:  denied  { create } for  pid=25429 comm="denyhosts.py" scontext=system_u:system_r:denyhosts_t:s0 tcontext=system_u:system_r:denyhosts_t:s0 tclass=unix_dgram_socket

node=(removed) type=SYSCALL msg=audit(1273590536.953:28425): arch=40000003 syscall=102 success=no exit=-13 a0=1 a1=bff0fddc a2=d4dff4 a3=1 items=0 ppid=1 pid=25429 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=567 comm="denyhosts.py" exe="/usr/bin/python" subj=system_u:system_r:denyhosts_t:s0 key=(null)



Hash String generated from  catchall,denyhosts.py,denyhosts_t,denyhosts_t,unix_dgram_socket,create
audit2allow suggests:

#============= denyhosts_t ==============
allow denyhosts_t self:unix_dgram_socket create;
Comment 1 Daniel Walsh 2010-05-11 17:21:08 EDT

*** This bug has been marked as a duplicate of bug 591290 ***

Note You need to log in before you can comment on or make changes to this bug.