Bug 591317 - pdfedit fails to compile on i686 with zlib.h errors
pdfedit fails to compile on i686 with zlib.h errors
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: zlib (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
: 599815 (view as bug list)
Depends On:
Blocks: 488651 599749
  Show dependency treegraph
 
Reported: 2010-05-11 17:03 EDT by Orion Poplawski
Modified: 2010-06-21 10:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-17 02:45:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2010-05-11 17:03:51 EDT
Description of problem:

pdfedit fails to compile on i686 with zlib.h errors:

g++ -c  -O2   -fmessage-length=0 -D_FORTIFY_SOURCE=2 -fno-strict-aliasing -fexceptions    -pipe -posix -ansi -std=c++98 -pedantic -I. -I/builddir/build/BUILD/pdfedit-0.4.5/src -I/builddir/build/BUILD/pdfedit-0.4.5/src/xpdf/  -I/usr/include -I/usr/include/freetype2  -I/usr/include -o pdfwriter.o pdfwriter.cc
In file included from pdfwriter.cc:32:
/usr/include/zlib.h:1583: error: declaration of C function 'off_t gzseek64(void*, off_t, int)' conflicts with
/usr/include/zlib.h:1567: error: previous declaration 'off64_t gzseek64(void*, off64_t, int)' here
/usr/include/zlib.h:1584: error: declaration of C function 'off_t gztell64(void*)' conflicts with
/usr/include/zlib.h:1568: error: previous declaration 'off64_t gztell64(void*)' here
/usr/include/zlib.h:1585: error: declaration of C function 'off_t gzoffset64(void*)' conflicts with
/usr/include/zlib.h:1569: error: previous declaration 'off64_t gzoffset64(void*)' here
/usr/include/zlib.h:1586: error: declaration of C function 'uLong adler32_combine64(uLong, uLong, off_t)' conflicts with
/usr/include/zlib.h:1570: error: previous declaration 'uLong adler32_combine64(uLong, uLong, off64_t)' here
/usr/include/zlib.h:1587: error: declaration of C function 'uLong crc32_combine64(uLong, uLong, off_t)' conflicts with
/usr/include/zlib.h:1571: error: previous declaration 'uLong crc32_combine64(uLong, uLong, off64_t)' here

See http://koji.fedoraproject.org/koji/taskinfo?taskID=2180724 for builds

Version-Release number of selected component (if applicable):
1.2.5-1.fc14
Comment 1 Orion Poplawski 2010-05-11 17:53:06 EDT
Apparently there has been some discussion of this on the zlib mailing list but no official resolution it seems.  Gentoo apparently has a patch in their 1.2.5-r2 package for this.
Comment 2 Jindrich Novy 2010-05-31 08:00:32 EDT
The same happens with the latest TeX Live 2010 build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=2219242
Comment 3 Jindrich Novy 2010-06-15 04:57:09 EDT
Gentoo uses this simple patch:

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sys-libs/zlib/files/zlib-1.2.5-lfs-decls.patch?revision=1.2

and no further breakages are reported for a while. Please apply this patch as well.
Comment 4 Ivana Varekova 2010-06-17 02:45:36 EDT
Thanks, fixed in 
zlib-1.2.5-2.fc14,
Comment 5 Hans de Goede 2010-06-21 10:52:40 EDT
*** Bug 599815 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.