Bug 591330 - attachments are inaccessible via evolution-mapi
attachments are inaccessible via evolution-mapi
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-mapi (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 18:20 EDT by Chad Feller
Modified: 2010-05-12 06:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-11 22:32:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console output on fail (1.49 KB, text/plain)
2010-05-11 18:21 EDT, Chad Feller
no flags Details
console output on success (1.79 KB, text/plain)
2010-05-11 18:22 EDT, Chad Feller
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 618416 None None None Never

  None (edit)
Description Chad Feller 2010-05-11 18:20:13 EDT
Description of problem:
attachments are sometimes inaccessible when using the mapi connector.  For instance  I have message X in my inbox, and the paperclip (attachment) icon is next to my message indicating that the message has an attachment.  However, when I click on the message, there is no indication in the message that there actually is an attachment.  That is, there is no option to download or view the attachment.  If I view the same message in OWA, I can see that the message has a pdf attached.

Other messages I can access the attachment perfectly fine.

Version-Release number of selected component (if applicable):
evolution-2.30.1-3.fc13.x86_64
evolution-mapi-0.30.1-1.fc13.x86_64

How reproducible:
sometimes

Steps to Reproduce:
1. click on message that has an attachment
2.
3.
  
Actual results:
no option is given to download or view the attachment

Expected results:
attachment can be viewed or downloaded.

Additional info:

on the message where the attachment is inaccessible, looking at the message source seems to indicate that there is no attachment, so this would seem to be some type of mapi connector failure.  Yet, the attachment flag is being set and that is getting through as the "paperclip" icon is being displayed in spite of this.

attaching two files, one is the console output on a message where the attachments are inaccessible, another is a message where they are accessible.
Comment 1 Chad Feller 2010-05-11 18:21:56 EDT
Created attachment 413277 [details]
console output on fail
Comment 2 Chad Feller 2010-05-11 18:22:30 EDT
Created attachment 413278 [details]
console output on success
Comment 3 Matthew Barnes 2010-05-11 22:32:57 EDT
Moving this upstream for better visibility.
Please see [1] for further updates.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=618416
Comment 4 Milan Crha 2010-05-12 06:10:18 EDT
I cannot reproduce this with PDF attachments on a message created by Outlook, but I can see something going wrong with eml attachments, as stated in the upstream bug. (I'm only letting you know, anything more would be better to deal with in the upstream bug report.)

Note You need to log in before you can comment on or make changes to this bug.