Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 591367 - unable to fetch DUD from http
unable to fetch DUD from http
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
high Severity high
: beta
: ---
Assigned To: Martin Sivák
Release Test Team
: Reopened
: 591371 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 23:03 EDT by Qian Cai
Modified: 2010-07-02 16:49 EDT (History)
2 users (show)

See Also:
Fixed In Version: anaconda-13.21.38-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 16:49:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qian Cai 2010-05-11 23:03:54 EDT
Description of problem:
DUD failed for HTTP method,
...
INFO:  transferring http://10.66.65.177/dd_sym53c8xx-rhel6.0-beta1.iso
INFO:  mounted loopback device /tmp/drivers on /dev/loop6 as /tmp/dd.img
ERROR: cannot find /tmp/drivers/x86_64/repodata, bad driver disk
ERROR: not a valid driver disk
...
When I looked inside the ISO, the layout was as the following,
# mount /dev/loop0 /tmp/drivers/
# ls /tmp/drivers/
rhdd3  rpms

As you can see, there is no /tmp/drivers/x86_64/repodata but /tmp/drivers/rpms/x86_64/repodata.

Version-Release number of selected component (if applicable):
RHEL6 public beta 1

How reproducible:
always
Comment 1 Martin Sivák 2010-05-12 02:23:07 EDT
This is already fixed in current anaconda build. It has nothing to do with http, just a mistake in one path check.

See commit f44f1c6105ae146f6af2ce972e0c31b548240d88.
Comment 4 Qian Cai 2010-05-18 00:23:37 EDT
*** Bug 591371 has been marked as a duplicate of this bug. ***
Comment 5 releng-rhel@redhat.com 2010-07-02 16:49:07 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.