Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 591378 - build_apache_snmp.sh fails with cannot run /bin/sh ./config.sub
build_apache_snmp.sh fails with cannot run /bin/sh ./config.sub
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: No Component (Show other bugs)
1.3.1
All Linux
high Severity high (vote)
: ---
: ---
Assigned To: Heiko W. Rupp
Corey Welton
:
Depends On:
Blocks: jon-sprint11-bugs
  Show dependency treegraph
 
Reported: 2010-05-12 00:40 EDT by Larry O'Leary
Modified: 2010-10-23 11:17 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-12 12:53:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry O'Leary 2010-05-12 00:40:39 EDT
Description of problem:
Unable to build Apache SNMP Connector module from source provided with JON 2.3.1 on Fedora or SuSE Linux system due to an error configure spits out when attempting to execute config.sub in the snmp2.0 directory.  

It appears that this is because config.sub and config.guess are missing.  I was able to get around this issue by executing automake -a from the snmp2.0 directory to add the missing files.

I have only seen and tested this issue on SuSE Linux Enterprise 11 and Fedora 11.
Comment 1 Charles Crouch 2010-05-18 23:28:40 EDT
We should see whether this is an issue on RHEL, if not then I suspect just a doc update should be sufficient here.
Comment 2 Heiko W. Rupp 2010-06-18 05:12:46 EDT
RHEL 5.5 needs a bunch of (additional) packages installed

- httpd-devel
- libtool
- automake

but building the modules for apache 2.0 and 2.2 fails with missing includes ( -I options are not correctly set) and 1.3 fails with some other error. 

As we are delivering binary versions, compiling from source is perhaps not that important.

The docs at http://rhq-project.org/display/JOPR2/Apache+2.x+SNMP+Config tell that automake is needed.
Comment 3 ezra di biase 2010-06-28 17:00:03 EDT
Hi to all,
anyone came to a solution?
 
I'm in a similar situation: Red Hat AS4, apache 2.0.52 and I need to compile because the binaries are linked to GLIBC_2.4 and on my system there is GLIBC_2.3.
Comment 4 Larry O'Leary 2010-06-28 17:17:05 EDT
Try the workaround mentioned in the description:

>   It appears that this is because config.sub and config.guess 
>   are missing.  I was able to get around this issue by executing 
>   automake -a from the snmp2.0 directory to add the missing 
>   files.

Basically, you will force automake to generate/add the missing files.
Comment 5 ezra di biase 2010-06-29 12:29:00 EDT
Hi all,
I solved following this post from RHQ Project: http://jira.rhq-project.org/browse/RHQ-1979

It was a Solaris environment bug but I tried and it worked.
Comment 6 Heiko W. Rupp 2010-07-09 07:26:06 EDT
r10793 adds a switch for Solaris that defaults to the RHEL behaviour
Comment 7 Corey Welton 2010-07-12 11:05:49 EDT
Confirmed that running automake works.  After running it, I got:


[root@core-01 snmp2.0]# automake -a
configure.in: no proper invocation of AM_INIT_AUTOMAKE was found.
configure.in: You should verify that configure.in invokes AM_INIT_AUTOMAKE,
configure.in: that aclocal.m4 is present in the top-level directory,
configure.in: and that aclocal.m4 was recently regenerated (using aclocal).
configure.in:32: installing `./config.guess'
configure.in:32: installing `./config.sub'
automake: no `Makefile.am' found for any configure output

And then reattempting the build was successful.

However, per comment #1, do we need to have this documented somewhere?
Comment 8 Corey Welton 2010-07-12 11:07:04 EDT
Marking this verified.
Comment 9 Corey Welton 2010-08-12 12:53:10 EDT
Mass-closure of verified bugs against JON.

Note You need to log in before you can comment on or make changes to this bug.