Bug 591419 - OpenLDAP connection freeze when using TLS
OpenLDAP connection freeze when using TLS
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openldap (Show other bugs)
5.5
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Jan Vcelak
Ondrej Moriš
: Regression, ZStream
: 591755 (view as bug list)
Depends On:
Blocks: 608112 653910
  Show dependency treegraph
 
Reported: 2010-05-12 04:25 EDT by Jan Zeleny
Modified: 2013-03-03 20:27 EST (History)
12 users (show)

See Also:
Fixed In Version: openldap-2.3.43-15.el5
Doc Type: Bug Fix
Doc Text:
- TLS connection to OpenLDAP server is created - the connection freezes for about three seconds - upstream patch applied to target this issue - the TLS connection to OpenLDAP server will not freeze for thee seconds after it is created
Story Points: ---
Clone Of:
: 608112 (view as bug list)
Environment:
Last Closed: 2012-02-21 00:26:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated upstream patch (928 bytes, patch)
2010-05-12 04:30 EDT, Jan Zeleny
no flags Details | Diff

  None (edit)
Description Jan Zeleny 2010-05-12 04:25:35 EDT
As a regression of fixed bug 509230, connection to slapd freezes for about 3 seconds every time it is made. Error output of slapd is filled with these messages:

tls_read: want=5 error=Resource temporarily unavailable

slapd runs at 100% CPU during that time. Package without the patch works fine.
Comment 1 Jan Zeleny 2010-05-12 04:30:05 EDT
Created attachment 413353 [details]
Updated upstream patch

I found that the original upstream patch was flawed. After creating my own patch I discovered there is already very similar upstream fix of this issue. This attachment is the upstream fix.
Comment 3 Jatin Nansi 2010-05-12 21:59:12 EDT
*** Bug 591755 has been marked as a duplicate of this bug. ***
Comment 6 Jeffrey Blank 2010-08-22 22:47:15 EDT
I have experienced the same problem, the one noted by Chris at https://bugzilla.redhat.com/show_bug.cgi?id=509230#c11 . 

I have also successfully reverted to an older package to avoid this problem (instead of configuring to disable TLS on the current version, which can also avoid the problem, but is obviously not desirable).

Please indicate if additional information would be helpful, or if a package update is expected for 5.5.  I also have debug traces, which are similar to the ones Chris posted.  I am also happy to share config files or other setup info, which are fairly simple.  Thanks!
Comment 10 Jan Vcelak 2010-11-16 07:58:40 EST
Fixed and built.
Comment 17 Jan Vcelak 2011-08-26 09:43:55 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
- TLS connection to OpenLDAP server is created
- the connection freezes for about three seconds
- upstream patch applied to target this issue
- the TLS connection to OpenLDAP server will not freeze for thee seconds after it is created
Comment 20 errata-xmlrpc 2012-02-21 00:26:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0155.html

Note You need to log in before you can comment on or make changes to this bug.