Bug 591423 - USB keyboard fails to suspend, triggering hibernation failure
Summary: USB keyboard fails to suspend, triggering hibernation failure
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: All
OS: Linux
Target Milestone: rc
: ---
Assignee: John Feeney
QA Contact: Red Hat Kernel QE team
Depends On:
Blocks: 846704
TreeView+ depends on / blocked
Reported: 2010-05-12 08:38 UTC by Stefan Assmann
Modified: 2013-01-10 07:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2012-12-03 20:39:38 UTC
Target Upstream Version:

Attachments (Terms of Use)
pm-suspend.log (7.29 KB, text/plain)
2010-05-12 08:38 UTC, Stefan Assmann
no flags Details
/Xorg.0.log (101.84 KB, text/plain)
2010-05-12 08:40 UTC, Stefan Assmann
no flags Details
lspci.txt (3.07 KB, text/plain)
2010-05-12 08:41 UTC, Stefan Assmann
no flags Details
dmesg.txt (85.92 KB, text/plain)
2010-05-12 12:36 UTC, Stefan Assmann
no flags Details

Description Stefan Assmann 2010-05-12 08:38:39 UTC
Created attachment 413354 [details]

Description of problem:
when trying to hibernate on Lenovo T500 the screen goes black there's disk activity for about 1-2 minutes then the disk activity stops with only the half-moon LED blinking. Another 1-2 minutes later the system woke up again on it's own.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. hibernate the system

Comment 1 Stefan Assmann 2010-05-12 08:40:08 UTC
Created attachment 413356 [details]

Comment 2 Stefan Assmann 2010-05-12 08:41:01 UTC
Created attachment 413357 [details]

Comment 4 RHEL Program Management 2010-05-12 10:39:52 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for

Comment 5 Matthew Garrett 2010-05-12 12:22:50 UTC
Can you attach dmesg?

Comment 6 Matthew Garrett 2010-05-12 12:23:04 UTC
From the failure case, that is.

Comment 7 Stefan Assmann 2010-05-12 12:36:48 UTC
Created attachment 413416 [details]

Comment 8 Matthew Garrett 2010-05-12 12:45:11 UTC
It looks like your USB keyboard failed to suspend for some reason. Is this reliably repeatable?

Comment 9 Stefan Assmann 2010-05-12 12:56:33 UTC
Happened to me twice now. I haven't change my physical setup and this worked with F12 and F13beta. I can do some more testing if you let me know what I should be looking for.

Comment 10 RHEL Program Management 2010-07-15 14:28:08 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 11 Matthew Garrett 2010-11-24 21:47:20 UTC
Did this ever happen again?

Comment 12 Stefan Assmann 2010-11-25 07:28:02 UTC
I'm not 100% sure because I gave up on hibernate because it was to unreliable for me and switched to suspend to RAM, which worked pretty good for me. Now I've already switched to F14. Feel free to close this bug.

Comment 13 RHEL Program Management 2011-10-07 15:02:35 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 14 Lenny Szubowicz 2012-12-03 20:39:38 UTC
I'm inheriting this open BZ. Since this problem report is somewhat old and comment 12 from the submitter indicates it might not be reproducible any more, I'm closing it.


Note You need to log in before you can comment on or make changes to this bug.